summaryrefslogtreecommitdiff
path: root/dev-python/os-service-types/os-service-types-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/os-service-types/os-service-types-1.3.0.ebuild
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/os-service-types/os-service-types-1.3.0.ebuild')
-rw-r--r--dev-python/os-service-types/os-service-types-1.3.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/os-service-types/os-service-types-1.3.0.ebuild b/dev-python/os-service-types/os-service-types-1.3.0.ebuild
new file mode 100644
index 000000000000..1a1319ad8b32
--- /dev/null
+++ b/dev-python/os-service-types/os-service-types-1.3.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A library to handle official service types for OpenStack and it's aliases."
+HOMEPAGE="https://github.com/openstack/os-service-types"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"