summaryrefslogtreecommitdiff
path: root/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'dev-python/opensearch-py/opensearch-py-1.1.0.ebuild')
-rw-r--r--dev-python/opensearch-py/opensearch-py-1.1.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
new file mode 100644
index 000000000000..e8a8167526a5
--- /dev/null
+++ b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for OpenSearch"
+HOMEPAGE="
+ https://pypi.org/project/opensearch-py/
+ https://github.com/opensearch-project/opensearch-py
+"
+SRC_URI="
+ https://github.com/opensearch-project/opensearch-py/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Uses 156 GB of RAM for the test suite, needs more work.
+RESTRICT="test"
+
+RDEPEND="
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ )
+"