summaryrefslogtreecommitdiff
path: root/dev-python/openpyxl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/openpyxl
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest4
-rw-r--r--dev-python/openpyxl/metadata.xml4
-rw-r--r--dev-python/openpyxl/openpyxl-3.0.6.ebuild30
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index bf81e13da16d..4189164e1fff 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1,3 +1,5 @@
DIST openpyxl-3.0.5.tar.bz2 2421647 BLAKE2B 60fc12188a608891a63513177e8e3399b3905ee9b4c4ff1631901ce0d99c3e05bc9413813d3c4f7bb9034e1d839f91e9dea5e610795c701a40d99f1011b08c45 SHA512 5f60f746b7b4bd32a018972f7c18adc0552a6d6904fcf1258db3fab28f21aa7b17e386b355ede41365889146e9aaa09911748a26343788477fd72ad5d1264974
+DIST openpyxl-3.0.6.tar.bz2 2423464 BLAKE2B 205db09634730a1da6c24bc8c407b2f3deeac712b4c2cbe69796c538c6911ccb3e7e003617ab9563df12a74d6ca9fb2b1b83d8d75f3b91c168d2053a14c15d66 SHA512 6996800c54746dc41b902cbea378181cdab5db916fd6863c673df25f84f71de67019e34d0034231d7c588bf56be3f8e16b3a52c198dcbe74465d0b088090c24a
EBUILD openpyxl-3.0.5.ebuild 744 BLAKE2B 744fea747ab6ad473bfdc4c085ad338bbf89aa2b44d6763ea1afacdb08a0783ee8897fc06a3e44474a296814111281910770722c81bcbda71077c32596bdb423 SHA512 911f5bc7885df98162d727218a6b2fb99c73f199395e3225b5fd4d2a40caa26fd1c3f2dd027cf3bdb4aeaa94803e05ab546c3aa4acfd0fb09f87ce646e4fe0a0
-MISC metadata.xml 532 BLAKE2B 72f6ec0d23613d0b6e52d8373622177d387d4345487c699b36d2d950ae90b1d01ea629c37071abfeea05af560f8db189d6fd3ed2b6a92a5fc5b194c318821c41 SHA512 0a01848687a019df8b161b411a77085f11d64f34326e90449861344f23de7af651e6082f73e1b17ceda38326e936ef4153186afa3a626bffa16f3435cbbba14a
+EBUILD openpyxl-3.0.6.ebuild 746 BLAKE2B 8bab5caba6dbab55689fc209d55be689538db6dd5f82d0163ff122bf0bc12b53a39f16aa7f7c7520a7cba4be33d69f52a7337d3f38956c64d64cbd26f7374fb2 SHA512 e36d3bda980c77d775d7302d097067ed69c5430bd5b262d36fd60d5b4acf9b4a8c5aec7794544b565b772110a8ecce2e0618d1c3780e838e2a831a2e4d852687
+MISC metadata.xml 535 BLAKE2B 59a57dfa41a492b88402a893a4c2e1a6bc624ada24584744ad2c142d1ba9bbad0172450e17cc2ab62068c7964c08066499b4cae59e39aef81bc7714ba86059f5 SHA512 30500339fc951ec3dbef77bcb5b0298b33bedc78ceb4733f9fac689da179096396da308214f012c40c54f718d74c6555b5795d763db197dfacceb46441b292a5
diff --git a/dev-python/openpyxl/metadata.xml b/dev-python/openpyxl/metadata.xml
index 740d5bd6fe78..4536ece60d52 100644
--- a/dev-python/openpyxl/metadata.xml
+++ b/dev-python/openpyxl/metadata.xml
@@ -8,8 +8,8 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">openpyxl</remote-id>
- <bugs-to>https://foss.heptapod.net/openpyxl/openpyxl/issues</bugs-to>
+ <bugs-to>https://foss.heptapod.net/openpyxl/openpyxl/-/issues</bugs-to>
<changelog>https://openpyxl.readthedocs.io/en/stable/changes.html</changelog>
- <doc>https://openpyxl.readthedocs.io</doc>
+ <doc>https://openpyxl.readthedocs.io/</doc>
</upstream>
</pkgmetadata>
diff --git a/dev-python/openpyxl/openpyxl-3.0.6.ebuild b/dev-python/openpyxl/openpyxl-3.0.6.ebuild
new file mode 100644
index 000000000000..5c4d4f8c1c20
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+# Upstream doesn't want to include tests in PyPI tarballs
+SRC_URI="https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )"
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest