summaryrefslogtreecommitdiff
path: root/dev-python/openpyxl/openpyxl-2.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/openpyxl/openpyxl-2.6.1.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/openpyxl/openpyxl-2.6.1.ebuild')
-rw-r--r--dev-python/openpyxl/openpyxl-2.6.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/openpyxl/openpyxl-2.6.1.ebuild b/dev-python/openpyxl/openpyxl-2.6.1.ebuild
new file mode 100644
index 000000000000..707b1dce67b3
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-2.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_COMMIT="134e08ea4301"
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="https://openpyxl.readthedocs.io/en/stable/"
+SRC_URI="https://bitbucket.org/${PN}/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/jdcal[${PYTHON_USEDEP}]
+ dev-python/et_xmlfile[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${PN}-${PN}-${MY_COMMIT}"
+
+python_test() {
+ pytest -v || die "Testing failed with ${EPYTHON}"
+}