summaryrefslogtreecommitdiff
path: root/dev-python/openapi-spec-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
commitf9a53aec073578673710687755db617717dd87d3 (patch)
tree9e9642aae0c5bc25cac799d6a2437229bbb76a76 /dev-python/openapi-spec-validator
parent7e110ec617b903791c3d309845e11a8b27f441cc (diff)
gentoo auto-resync : 11:07:2023 - 10:29:18
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest2
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index 45b3ec9635f8..a217201d75b0 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,5 +1,7 @@
DIST openapi_spec_validator-0.5.6.tar.gz 33031 BLAKE2B a884ceb915f232232406bd880a7eef9e588e1a42ac9a78c2e23f91cbd71e9af471c764550a9dd214ef68ec24ede7ab0ba4624429e4fd8133011489d0039aeae7 SHA512 ea1e810ecf49ff3d237e3368cd2cbcc6b733e9657f101759860ef16d3e2f14c97ccfe52fae2897d12a50c803d709d61d7ef8b40b288e5f73265da9ac5c88280b
DIST openapi_spec_validator-0.5.7.tar.gz 33722 BLAKE2B 71096a996d335b60d6646d96390e580952a1e27829aa807c4b333ee11a7925bc1bc10f4440c79fc6d4a8321dfd3bab9ec86bf79bef6c7139835b7f8035cbc061 SHA512 63dafc0bc459d8ad097d0a98a3d23e67ae37c0004ce6d53ad999b037f2a6743c95e13ae22920403368c37f8877665c104ac20e1f58532cffd8df54c800a6cf7d
+DIST openapi_spec_validator-0.6.0.tar.gz 33646 BLAKE2B cf8d397602b147872e86c0f236731ec477e20775aa63a61162e66deb7d4b81ef91bd86b67d2dfddf5d6b160c37b7eab4ddb1d10975ada8dc13aebdc088e4483a SHA512 71434f131f34902210237940d75f07f250b296c3e1814e03f0eaae436321ca11ac63d0014c85ad571852e66b2e11545c9d0cf21d771c0c67210a60c1f9094cc2
EBUILD openapi-spec-validator-0.5.6.ebuild 1778 BLAKE2B baf1415550d6d0bb88e05013540d2b5676127c459f312dc49e2f7a894960249fe55a5817a89aa4a37be3521d05b61b3dc4b7a6215f1a89012ad2f4a2b82051ce SHA512 bba29039ea42f8b35a8e5174b2b398be97aac3e78e006572464f2482d0fd3eb6ceac386b779e71ee9f5a1c6c96c87a35597436e0a2380009ee65833c1f914e28
EBUILD openapi-spec-validator-0.5.7.ebuild 1742 BLAKE2B ef47ba72f8726d6222353d7bd7c6349ad9e9932ca7796ee5e1b761de574bfdcf6e92711db894767d9ac1f1873be9016f49a5e5690a200d8b6e571837297f0a80 SHA512 e711f32b88727de195019b7ee1ea48b9ae3cb9a78f3059a815c7c3e3ce1f633db23c1dc7ce6a0a9d7e8ecdaf32627f2b02a22df95d7b655ae28d65fb8fb5c0cb
+EBUILD openapi-spec-validator-0.6.0.ebuild 1612 BLAKE2B 9c823e218507f49cbe19f51d0b5e03d12782e5eb157ecf4031ace59e62f9bfda111b5239c5a0bbcb51b8dd2672053f557d4f693b70d686e73a11251622a3953e SHA512 584a362ef932d2760a50b91231155ee27a14a19d5fac367278527be2ab3595241ae7d7e0dcf9d68ef628e713f1034f8a0b15b624fd9615f4fe4326b956510127
MISC metadata.xml 405 BLAKE2B 82dfdb0a9a068a90ad245a33da95883f863571b12e3d354cee5b7e10b9c098f3635b25fc1871db3b384c5218c2305c90e9f185c97619ba142735b03de90bde01 SHA512 a3f926750e11ce7b8960fa7adef139a329b7dac777c78acfc2cf24225862d8f04a2bb8edba36f99aabd1ea44f93220afefafe060dce6418fa03f360c129a344c
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
new file mode 100644
index 000000000000..3bcaf2ceef03
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}