summaryrefslogtreecommitdiff
path: root/dev-python/openapi-spec-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-10 12:09:13 +0100
commit35d60f48c1e8e3d48626e53a1933c55805177d20 (patch)
tree0754900eff547564866e4e7265a5f0789874f907 /dev-python/openapi-spec-validator
parentdd14643cac4a1aa6ce4151cea5c424577434968b (diff)
gentoo auto-resync : 10:10:2023 - 12:09:13
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest2
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.7.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index fede7d61df3f..cd838f56cb40 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,5 +1,7 @@
DIST openapi_spec_validator-0.5.7.tar.gz 33722 BLAKE2B 71096a996d335b60d6646d96390e580952a1e27829aa807c4b333ee11a7925bc1bc10f4440c79fc6d4a8321dfd3bab9ec86bf79bef6c7139835b7f8035cbc061 SHA512 63dafc0bc459d8ad097d0a98a3d23e67ae37c0004ce6d53ad999b037f2a6743c95e13ae22920403368c37f8877665c104ac20e1f58532cffd8df54c800a6cf7d
DIST openapi_spec_validator-0.6.0.tar.gz 33646 BLAKE2B cf8d397602b147872e86c0f236731ec477e20775aa63a61162e66deb7d4b81ef91bd86b67d2dfddf5d6b160c37b7eab4ddb1d10975ada8dc13aebdc088e4483a SHA512 71434f131f34902210237940d75f07f250b296c3e1814e03f0eaae436321ca11ac63d0014c85ad571852e66b2e11545c9d0cf21d771c0c67210a60c1f9094cc2
+DIST openapi_spec_validator-0.7.0.tar.gz 36700 BLAKE2B aadaa34259900af7e2eb120ac7ccd6ea50d29ddd2c49edbd11c1c95f611dfc68edd580f4c5044a1c91ede2c421f2ef0b8e35dca89c5b997b6fc6211c68126b09 SHA512 a9e2b254d6855cfb4127eac44a0589e674748b2be6c68dd30e24144271096e82b336913b06e00407a88e6f3d3fdd0079a0c9489755dc68110d92d2b686f695ac
EBUILD openapi-spec-validator-0.5.7.ebuild 1744 BLAKE2B 37a91c53390ca5d2504ba3476efb7b7bb7a7e43c122e72c55e0f8c9d763855a72698fcc55bc526a34814100598a360d3b0b5c11cef8da3750e829fe19001a515 SHA512 0c66c02af3ac3c2a3332b13ca7058c11e806836d8ab25c54e90338e006597e4b4b4c55fd6a650a17a4f2adbcb8119c5464a2052d3868695c772478bf78a4c4f6
EBUILD openapi-spec-validator-0.6.0.ebuild 1643 BLAKE2B 58751a93af44d74db102d808c0c3777f7067d66bc0f1fba0da4d45ad4e22d535436e11537ebff1dbb09764dd0648b6a3a733276ed0790a512d32e5af6d71f5dd SHA512 419ea5af776537546205cea302ed4dc9af5a2c6ec8d9edc323830fcbf307c73fa831ac6407dac1714d0929bdf229cdaa888efbbd9505aac8d7c5895642f6f43b
+EBUILD openapi-spec-validator-0.7.0.ebuild 1643 BLAKE2B 58751a93af44d74db102d808c0c3777f7067d66bc0f1fba0da4d45ad4e22d535436e11537ebff1dbb09764dd0648b6a3a733276ed0790a512d32e5af6d71f5dd SHA512 419ea5af776537546205cea302ed4dc9af5a2c6ec8d9edc323830fcbf307c73fa831ac6407dac1714d0929bdf229cdaa888efbbd9505aac8d7c5895642f6f43b
MISC metadata.xml 405 BLAKE2B 82dfdb0a9a068a90ad245a33da95883f863571b12e3d354cee5b7e10b9c098f3635b25fc1871db3b384c5218c2305c90e9f185c97619ba142735b03de90bde01 SHA512 a3f926750e11ce7b8960fa7adef139a329b7dac777c78acfc2cf24225862d8f04a2bb8edba36f99aabd1ea44f93220afefafe060dce6418fa03f360c129a344c
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.7.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.7.0.ebuild
new file mode 100644
index 000000000000..6467dae04d40
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}