summaryrefslogtreecommitdiff
path: root/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-11 10:29:19 +0100
commitf9a53aec073578673710687755db617717dd87d3 (patch)
tree9e9642aae0c5bc25cac799d6a2437229bbb76a76 /dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
parent7e110ec617b903791c3d309845e11a8b27f441cc (diff)
gentoo auto-resync : 11:07:2023 - 10:29:18
Diffstat (limited to 'dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild')
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
new file mode 100644
index 000000000000..3bcaf2ceef03
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
+ tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+ tests/integration/validation/test_validators.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}