summaryrefslogtreecommitdiff
path: root/dev-python/openapi-core
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/openapi-core
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/openapi-core')
-rw-r--r--dev-python/openapi-core/Manifest3
-rw-r--r--dev-python/openapi-core/metadata.xml12
-rw-r--r--dev-python/openapi-core/openapi-core-0.14.2.ebuild63
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
new file mode 100644
index 000000000000..5fe7f2b8400e
--- /dev/null
+++ b/dev-python/openapi-core/Manifest
@@ -0,0 +1,3 @@
+DIST openapi-core-0.14.2.gh.tar.gz 57519 BLAKE2B 06dfd284612ca11a271f075444db9b859ca5416e31594680d6b32abec1fe917105f213209d1bfcb9664b265ea3d62839579134e8e104754075cd692d1ba7a99a SHA512 19a2508d56053214993abed7d173d17b55a80dac6421681d7c64082f910bf9cb03c99d4006a2cd883d51d54f11a18f90188f141a78b9d69a9a031c284a14f8f1
+EBUILD openapi-core-0.14.2.ebuild 1733 BLAKE2B ba75a26c077c9b9ac1c09f321c941d96cfbc4b37404d77481d9d0a03ddf93e931ad4a5b623a7bc3fcf48c4157b4f31989c0fdaa45e0f132d5a1d54a35173e94c SHA512 cbe22ad4328af6634c37a4348edca2ee841db605f4d09a3a4c4a63548d077acad7bea0742a375229a0c777bfb4dff137ea3c40ebc256486c810e6b17e6b3490d
+MISC metadata.xml 376 BLAKE2B bf1f9cf9377b172dfb5f916332dbf9d1e485f3ca1f31f754afac41931598c1780c474989edbfcf39bbfd4ceb8e8030280cf0997514dfb8e02bf3294176fc3dfd SHA512 c7fbdc21a2ea86abe5bcf4a3e8ba97634a447926ce999aff761965ff411fb05b09fab5e5338da5f8a8486a6b024cfeb27cfb9d9fbbfc9bad6f9dabaca1c82799
diff --git a/dev-python/openapi-core/metadata.xml b/dev-python/openapi-core/metadata.xml
new file mode 100644
index 000000000000..13f408253cd2
--- /dev/null
+++ b/dev-python/openapi-core/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">p1c2u/openapi-core</remote-id>
+ <remote-id type="pypi">openapi-core</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/openapi-core/openapi-core-0.14.2.ebuild b/dev-python/openapi-core/openapi-core-0.14.2.ebuild
new file mode 100644
index 000000000000..8f30b58a2c65
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.14.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/dictpath[${PYTHON_USEDEP}]
+ dev-python/openapi-schema-validator[${PYTHON_USEDEP}]
+ dev-python/openapi-spec-validator[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # falcon not packaged
+ rm -r tests/integration/contrib/falcon || die
+
+ # Theses tests fail to collect
+ rm tests/integration/validation/test_security_override.py || die
+ rm tests/integration/validation/test_read_only_write_only.py || die
+
+ # There's a problem in the test suite here
+ rm tests/unit/unmarshalling/test_unmarshal.py || die
+ rm tests/integration/contrib/django/test_django_rest_framework_apiview.py || die
+
+ sed -i -e '/--cov/d' setup.cfg || die
+ distutils-r1_src_prepare
+}