summaryrefslogtreecommitdiff
path: root/dev-python/openapi-core/openapi-core-0.17.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-16 07:40:50 +0100
commitbb5caf02fffada276b5aa598b3b6faea88ca0784 (patch)
treebfa61792a9b53240a85c99f215a14731f74bdd3a /dev-python/openapi-core/openapi-core-0.17.2.ebuild
parent98dd97c6dc5b5b4ad4bb19efeb7f314cc52f43ff (diff)
gentoo auto-resync : 16:06:2023 - 07:40:49
Diffstat (limited to 'dev-python/openapi-core/openapi-core-0.17.2.ebuild')
-rw-r--r--dev-python/openapi-core/openapi-core-0.17.2.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/openapi-core/openapi-core-0.17.2.ebuild b/dev-python/openapi-core/openapi-core-0.17.2.ebuild
new file mode 100644
index 000000000000..a9480b6e0bf6
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.17.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-spec-0.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.6[${PYTHON_USEDEP}]
+ <dev-python/lazy-object-proxy-2[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.4.2[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-aiohttp-1.0.4[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # falcon is not packaged
+ tests/integration/contrib/falcon
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}