summaryrefslogtreecommitdiff
path: root/dev-python/olefile/olefile-0.47.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-04 23:01:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-04 23:01:41 +0000
commitb3bfc7186e4f820493aa2eb8cc65f0efba7ed6f6 (patch)
treee60d25f1e0a33dacce9044e179c8dc93f596bb2a /dev-python/olefile/olefile-0.47.ebuild
parent4c552e09a1ece7792f2a20ccf4322348acbe3139 (diff)
gentoo auto-resync : 04:12:2023 - 23:01:41
Diffstat (limited to 'dev-python/olefile/olefile-0.47.ebuild')
-rw-r--r--dev-python/olefile/olefile-0.47.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/olefile/olefile-0.47.ebuild b/dev-python/olefile/olefile-0.47.ebuild
new file mode 100644
index 000000000000..71181806677f
--- /dev/null
+++ b/dev-python/olefile/olefile-0.47.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="
+ https://www.decalage.info/olefile/
+ https://github.com/decalage2/olefile/
+ https://pypi.org/project/olefile/
+"
+SRC_URI="
+ https://github.com/decalage2/olefile/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests unittest