summaryrefslogtreecommitdiff
path: root/dev-python/odfpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/odfpy
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/Manifest2
-rw-r--r--dev-python/odfpy/odfpy-1.3.6.ebuild16
2 files changed, 4 insertions, 14 deletions
diff --git a/dev-python/odfpy/Manifest b/dev-python/odfpy/Manifest
index 672a6d2c176e..6306fabca263 100644
--- a/dev-python/odfpy/Manifest
+++ b/dev-python/odfpy/Manifest
@@ -1,3 +1,3 @@
DIST odfpy-1.3.6.tar.gz 691122 BLAKE2B aaaf2c1613beb6775d22e4d1739b7c144d8046e687f0dc8f7b7b1ea7400cc32dd572ed5a1cd12cb01c5fec27b5c37950b710b279a46d60da8735154d2b2d7030 SHA512 09f3fbce633949035842cff16d2e016271b7f6abf04d74fcaa712c9b3afa18943dd566a2d88a7256a0a52d88ea689d6ef8262f6d8d67d6ea1025aa56e10300f8
-EBUILD odfpy-1.3.6.ebuild 923 BLAKE2B 23fa3442c6697ca799e6b992c54e2f3ab1ccd3da31dca67439eecc3c674ab1cf0d07a0ca69ff53aae94f212ee4a3f5e8090de4de10272f43f11d35993af914fc SHA512 5855381bc1c4aabace912c554f8b8e868c14951915ab90d93ec50f5bac16e34ae505cf4bdf1f9e82c1b88a3a036258d0bd1d98921a150bd0476e502913545174
+EBUILD odfpy-1.3.6.ebuild 602 BLAKE2B 695a1b03048846eb367f54bc8b608bcb6ea9ea08ee7250773e5e50487c394bb085b11735af45e4c5a095349c2aa7f33027c53ef6405a0b39f5ba539de84c7a08 SHA512 5123d852f5a84ad068d55f7a2a6a3126f7d37861261e671486c57767db72f028e64a7ccd94134fabbc450dde85533653cf4a87d4508e989642ce89db1aefe2c1
MISC metadata.xml 308 BLAKE2B 4d370440c480d97acc4b9b2e51aeb78f27227e8dd2c5acfdb99747b6b2eabdd624f8a8f90af28287849216d874bbcc81bb9ca8cbf78c1221e947fd479476b1db SHA512 919a3c6c182828bf99396da71e83f0b982aadcdf0e0c5e6e7f29e15cab19e2d3c6d5afc26864a324055e97be9563cc30ef10b701716678c7cd44e8403adaccde
diff --git a/dev-python/odfpy/odfpy-1.3.6.ebuild b/dev-python/odfpy/odfpy-1.3.6.ebuild
index ce7cc64b9f96..d04250e5a2a1 100644
--- a/dev-python/odfpy/odfpy-1.3.6.ebuild
+++ b/dev-python/odfpy/odfpy-1.3.6.ebuild
@@ -3,10 +3,7 @@
EAPI=7
-# Classifier: Programming Language :: Python :: 2 :: Only
-# py3 fails one test, pypy anpother.
-# Notes on page of home repo reports support of python3.
-PYTHON_COMPAT=( python{3_6,3_7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -17,16 +14,9 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="examples test"
-RESTRICT="!test? ( test )"
+IUSE="examples"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-python_test() {
- pytest -v || die "Tests failed with ${EPYTHON}"
-}
+distutils_enable_tests pytest
python_install_all() {
if use examples; then