summaryrefslogtreecommitdiff
path: root/dev-python/oct2py/oct2py-5.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 23:46:05 +0000
commitbb262580ec0b56a32797f121e627928d103e6bb1 (patch)
treeb3b80cb753a087635c972352ce99fed1d01f286b /dev-python/oct2py/oct2py-5.5.1.ebuild
parent35e3ee5faf74dc69409f957f81a6848d4d24c49f (diff)
gentoo auto-resync : 30:12:2023 - 23:46:05
Diffstat (limited to 'dev-python/oct2py/oct2py-5.5.1.ebuild')
-rw-r--r--dev-python/oct2py/oct2py-5.5.1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/oct2py/oct2py-5.5.1.ebuild b/dev-python/oct2py/oct2py-5.5.1.ebuild
deleted file mode 100644
index 5c9e34378089..000000000000
--- a/dev-python/oct2py/oct2py-5.5.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python to GNU Octave bridge"
-HOMEPAGE="
- https://github.com/blink1073/oct2py
- https://blink1073.github.io/oct2py/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/numpy-1.12[${PYTHON_USEDEP}]
- >=dev-python/octave_kernel-0.34.0[${PYTHON_USEDEP}]
- >=dev-python/scipy-0.17[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/nbconvert[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- )"
-
-EPYTEST_DESELECT=(
- # No graphics toolkit available: 743589
- "oct2py/ipython/tests/test_octavemagic.py::OctaveMagicTest::test_octave_plot"
-)
-
-distutils_enable_sphinx docs/source \
- dev-python/numpydoc dev-python/sphinx-bootstrap-theme dev-python/sphinx-rtd-theme
-distutils_enable_tests pytest
-
-PATCHES=( "${FILESDIR}"/${PN}-5.2.0-mask-pkg-load-test.patch )
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- docinto examples
- dodoc -r example/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}