summaryrefslogtreecommitdiff
path: root/dev-python/objgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-python/objgraph
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-python/objgraph')
-rw-r--r--dev-python/objgraph/Manifest2
-rw-r--r--dev-python/objgraph/objgraph-3.6.1.ebuild8
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/objgraph/Manifest b/dev-python/objgraph/Manifest
index 2cda44cb17f1..7e9ec61e2044 100644
--- a/dev-python/objgraph/Manifest
+++ b/dev-python/objgraph/Manifest
@@ -1,3 +1,3 @@
DIST objgraph-3.6.1.tar.gz 759513 BLAKE2B 875a4027b79446302755d00296ce0ae59d267f3996f206c8319a93cc8d5f53a0f26cf4701047d3b03beb3906bc5d70c23cdecfc135204d9fd9fea55d85e07a65 SHA512 9a15340aedb31e849739ec0667fefb52f99a94244540a7e1c0387299ad5fbbde05521ea91b959bc96204c4a62f796183377c6031af9c6a67828a91939f15225a
-EBUILD objgraph-3.6.1.ebuild 1274 BLAKE2B f196e1a796c61c7a459e57261f0b58aa0a4b6d91ac3ff156a9b1aa8c638f37656b091a3fd7f42be0b7181a5440c4e5e41583d6cccf262d3d7d114a7d8a4e964a SHA512 68c023d8a0ac5d4459b6a228d5ce5d65730e04209ddf04c819a3bf4a99c7dfb399508a3a0fa8516ddb693b32330fa6ce6cdff191f9a96c347539a76021737849
+EBUILD objgraph-3.6.1.ebuild 1443 BLAKE2B 187a1b91a87601c3baf20a4ef25355328f46a36abe7031fa038e73f425df2d1e1908f8fa8b49ad32e982e250ec0ba919aefa6a344184b86a22aeaee006302319 SHA512 b0e9fd96a08a1778404a412d1b32bd4491cbdd880373f637e70702125ca1ac60d2ada76b06371a258ed0c7c260777bc0f20a750ab50b3bcc590d0ea9c32a88bf
MISC metadata.xml 514 BLAKE2B 3da44f63b9604c7f730f9efc543d102bd2660eea11faeb29c6977b5cecf647d15c3075a9a20e81f9e35b3f08b2d51d47a6c1b63d9928bb56c22baaf61f1ced15 SHA512 5521d5ac2053e45ee1c7fec6ae176956f5823c22c144b8bcbfb47c2ca29c6595abfe45a3fd90a9a058b927157a22196dc17b14c6832a685214c4d2ebbe59c959
diff --git a/dev-python/objgraph/objgraph-3.6.1.ebuild b/dev-python/objgraph/objgraph-3.6.1.ebuild
index c9d284359d22..97a9a7b2b589 100644
--- a/dev-python/objgraph/objgraph-3.6.1.ebuild
+++ b/dev-python/objgraph/objgraph-3.6.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -47,6 +47,12 @@ python_test() {
tests.py::StringRepresentationTest::test_short_repr_mocked_instance_method_bound_with_mocked_name
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/mgedmin/objgraph/issues/80
+ tests.py::StringRepresentationTest::test_edge_label_frame_locals
+ )
+ ;;
esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1