summaryrefslogtreecommitdiff
path: root/dev-python/objgraph/objgraph-3.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-python/objgraph/objgraph-3.6.1.ebuild
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-python/objgraph/objgraph-3.6.1.ebuild')
-rw-r--r--dev-python/objgraph/objgraph-3.6.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/objgraph/objgraph-3.6.1.ebuild b/dev-python/objgraph/objgraph-3.6.1.ebuild
index c9d284359d22..97a9a7b2b589 100644
--- a/dev-python/objgraph/objgraph-3.6.1.ebuild
+++ b/dev-python/objgraph/objgraph-3.6.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -47,6 +47,12 @@ python_test() {
tests.py::StringRepresentationTest::test_short_repr_mocked_instance_method_bound_with_mocked_name
)
;;
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # https://github.com/mgedmin/objgraph/issues/80
+ tests.py::StringRepresentationTest::test_edge_label_frame_locals
+ )
+ ;;
esac
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1