summaryrefslogtreecommitdiff
path: root/dev-python/oauth2client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/oauth2client
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/oauth2client')
-rw-r--r--dev-python/oauth2client/Manifest3
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.3-r1.ebuild61
-rw-r--r--dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild2
3 files changed, 2 insertions, 64 deletions
diff --git a/dev-python/oauth2client/Manifest b/dev-python/oauth2client/Manifest
index 789c252f232a..defa374d519c 100644
--- a/dev-python/oauth2client/Manifest
+++ b/dev-python/oauth2client/Manifest
@@ -1,5 +1,4 @@
AUX oauth2client-4.1.3-py38.patch 1782 BLAKE2B 751b62649cd7222230f809c7e957636e351cddb3588c1da112443b09067c73cc6ada588697dd36f9b6ed2115238f8f811bc5502b17c75b2f65be655b4199dc9f SHA512 3e03d7105e76206e63858a32a25dfd5bbf997ced6abafd75d0f4973528ee91cb28200854ccfa519945573992f454c18d2acad5784693acffc7509ddcb13908a8
DIST oauth2client-4.1.3.tar.gz 185589 BLAKE2B 6cd61448e0d55cef7f2ba640c8cbb50ac83e76d0993391eb0acb3e156f937fcdee80576c9d45d505235a9f266495069664ccbfafd649a4e2d7a0990517ee8cb6 SHA512 80f49e09a6dd6767307a2c278544926fbf20b4f55e4cf83563ac7a7c1043622bd3c8c7fcf6de62896b623ca8c7947b309a5e6bf2b7cb0fccff3ff7634386b287
-EBUILD oauth2client-4.1.3-r1.ebuild 1722 BLAKE2B 3229060062fc40acb5ea8a5028c94cae5979959d698b76341f8cfb1615b055e46327dd517fc491c0298256b67b553dfe7e4e6d2565dbd160e80097e808e7effb SHA512 38c7d3524591fa24547a6d2a37aa66c39cf002c2867a99c46de06361e7f4d162bcf4a88950117a58a5ea422c85dbf2f74598874d9deb3a2fe62564e5361bddf8
-EBUILD oauth2client-4.1.3-r2.ebuild 1427 BLAKE2B ecd3ee975db3d8063346ef9692e147108b1f192c31f978fb019034f3a062c70ef604052736c79d0d489558eb58381ca031d62fb870b9a4cb3b5b371b9b516f47 SHA512 bee11a308927b96f41311aa9aba21f7aaddc303c00f7702c74a11d65e8478ae21984f0ac6034c52a4cccfa7346987541bdcd71956dba61dc7a00d1f2fbef5cbf
+EBUILD oauth2client-4.1.3-r2.ebuild 1425 BLAKE2B 84c5c4fd7aa75b495d23118c53f28085a010e6eb8adafcb8550cfff329216e868ea9d5679d09e4c45dad4f85a90af6c79a4190f0ec4f62a39397c493ece02b95 SHA512 dc9ff81c0a2d69e44441ec3acd48587fbde8bfaa6c91b93e2bc12d6b130b44c94edad14dc3d564b4e48be9d6527c121f336d67c72ecc59ea657755180b7ed267
MISC metadata.xml 403 BLAKE2B 53ea3fd7507fa9760d7af00c61e4598779e775fd3ab7e498908aa39f3472dff0cdd8246d7c2e7b62ebbfbf01c7ed9c1725dbb276e8685cb46ea77bcc2c02f9d2 SHA512 1cdf21510872f686912e699627a0252119ca25a3198183d74608a12e07bf14538398794e235ccdfdec06e1aafc52cbb693748bfde50855c083a59e3f1ada3870
diff --git a/dev-python/oauth2client/oauth2client-4.1.3-r1.ebuild b/dev-python/oauth2client/oauth2client-4.1.3-r1.ebuild
deleted file mode 100644
index 21462801d204..000000000000
--- a/dev-python/oauth2client/oauth2client-4.1.3-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for accessing resources protected by OAuth 2.0"
-HOMEPAGE="https://github.com/googleapis/oauth2client"
-SRC_URI="https://github.com/googleapis/oauth2client/archive/v${PV/_p/-post}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${P/_p/-post}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
- >=dev-python/pyasn1-modules-0.0.5[${PYTHON_USEDEP}]
- >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- !<=dev-python/google-api-python-client-1.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/sqlalchemy[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests nose
-
-PATCHES=(
- "${FILESDIR}/oauth2client-4.1.3-py38.patch"
-)
-
-python_prepare() {
- # keyring is not fuly supported by pypy yet, because dbus-python can't support pypy
- # oauth2client -> keyring -> secretstorage -> dbus-python
- # https://github.com/mitya57/secretstorage/issues/10
- case $PYTHON in
- pypy|*pypy|*pypy3|pypy3) \
- find "${BUILD_DIR}/.." -name '*keyring*py' -delete ;;
- esac
-}
-
-python_test() {
- nosetests -v \
- -e appengine \
- -e django_util \
- -e test_multiprocess_file_storage \
- -e test_bad_positional || die "tests fail with ${EPYTHON}"
- # appengine - requires appengine
- # django_util - requires django
- # test_multiprocess_file_storage - requires fasteners
- # test_bad_positional - expects TypeError, gets ValueError
-}
diff --git a/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild b/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
index 29d0198dbeb8..134a99098d66 100644
--- a/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
+++ b/dev-python/oauth2client/oauth2client-4.1.3-r2.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}"/${P/_p/-post}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]