summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc/numpydoc-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-15 12:04:03 +0100
commit7fa8a1e3f149eea4c844c47cfe26136ed7614c58 (patch)
treee514d1b9999d088064bee1e34a3a3c500d6d7a07 /dev-python/numpydoc/numpydoc-1.6.0.ebuild
parentd993571e2ee444d08f4e9e90d493ee37338657e3 (diff)
gentoo auto-resync : 15:04:2024 - 12:04:02
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.6.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.6.0.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.6.0.ebuild b/dev-python/numpydoc/numpydoc-1.6.0.ebuild
deleted file mode 100644
index dcd8259986f6..000000000000
--- a/dev-python/numpydoc/numpydoc-1.6.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
-HOMEPAGE="
- https://numpydoc.readthedocs.io/en/latest/
- https://github.com/numpy/numpydoc/
- https://pypi.org/project/numpydoc/
-"
-SRC_URI="
- https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-RDEPEND="
- >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
- >=dev-python/sphinx-5[${PYTHON_USEDEP}]
- >=dev-python/tabulate-0.8.10[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # https://github.com/numpy/numpydoc/pull/523
- "${FILESDIR}/${P}-py3.12-flt-depr-warn.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # these require Internet (intersphinx)
- numpydoc/tests/test_full.py::test_MyClass
- numpydoc/tests/test_full.py::test_my_function
- )
- epytest -o addopts= --pyargs numpydoc
-}