summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc/numpydoc-1.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 19:34:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 19:34:30 +0100
commit948f9476d6a417da6048d4291bf36b0507293d63 (patch)
tree794c4cb065d606084053aeadc0b6a44bce61a6f6 /dev-python/numpydoc/numpydoc-1.5.0.ebuild
parentbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (diff)
gentoo auto-resync : 10:10:2022 - 19:34:30
Diffstat (limited to 'dev-python/numpydoc/numpydoc-1.5.0.ebuild')
-rw-r--r--dev-python/numpydoc/numpydoc-1.5.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/numpydoc/numpydoc-1.5.0.ebuild b/dev-python/numpydoc/numpydoc-1.5.0.ebuild
new file mode 100644
index 000000000000..e031076473c2
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="
+ https://numpydoc.readthedocs.io/en/latest/
+ https://github.com/numpy/numpydoc/
+ https://pypi.org/project/numpydoc/
+"
+SRC_URI="
+ https://github.com/numpy/numpydoc/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest --pyargs numpydoc
+}