summaryrefslogtreecommitdiff
path: root/dev-python/numpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-18 00:10:02 +0100
commitccaccfe4f1da8c11d9fa110f6e4eb847358769d7 (patch)
treeff02c95ae3d9a1e73e2a182e268161743d81a88b /dev-python/numpy
parent74e526c590f52d24a213e25f77858ae0b34ec2c8 (diff)
gentoo auto-resync : 18:06:2024 - 00:10:02
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/Manifest2
-rw-r--r--dev-python/numpy/numpy-2.0.0.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index 56e5f8c419e2..74c79028889e 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,6 +1,8 @@
AUX numpy-2.0.0_rc2-gcc14.patch 892 BLAKE2B 32e2faa0c5979960a7293d9d709ee75d57b7ee182a043ecb942b93b3b0c4e49837b3302ff2dbfafbfa01ac6a1578aa74a0f0d16222218326efc7d8dc96328bd2 SHA512 d2d184e94140652ce42a53d3b1c146dd2ae0844a3f2607238403450690b2023029ff243343b6f5fb2a05e12ed220961002681cedba526be44858285934db328b
DIST numpy-1.26.4.tar.gz 15786129 BLAKE2B ee759d3a857111bc494d5e989a7b005375d942b2a89cda69be4a3bd7c6cb195003fd2a8a0535f1858d8977ff688b0ec36360dcba9c3160206eedce5e28f191ef SHA512 f7121ab4099fa0686f9c095d456baa4a5869d651d7b7a06385f885f329cf08f11024b5df5e7b4ee705970062a8102ec4f709512eabbfd5c9fccce4ef83b9c208
+DIST numpy-2.0.0.tar.gz 18326228 BLAKE2B e3d1084b79e0e55cd9087bb34dc116e6c9d6ab14a416a07f727b9f5d5a9db236ecf74a53b7e758d078781c5e565e5557912962f2ddbfff7251ec5b231fabe01d SHA512 cd5612ce2db4be87afa8479c508c256c9ff7f1b15a6b010eb06ba962759cc26552b512ec82711680bab1ebedeb06dfc8d7bff9cec63c94efacaadd719448b287
DIST numpy-2.0.0rc2.tar.gz 18323588 BLAKE2B e2d5d03594d0cba360d4e85207818d15a0761f37cc3fb366f8f9f8bdd97743fe0cf0d09a34319c8b6af29b2bc1fc32a7f5be30a5fa2bdebffe455baff05caf7e SHA512 f86b27264c5274823aa11cbedf17c08f81f9acd05430bf40cccbbe8dcff523410629795ca5927d7f8e6c152272b274d777b64f547d23f50d11ae9fd656fd773d
EBUILD numpy-1.26.4.ebuild 5091 BLAKE2B 91cf0872ed9d2ce980079f780ef545a617b29398b575b041f8674ea93f079e8c31dace23a884ef95962eb5b81670145792f0a0aaf12dd298f479c93426816075 SHA512 760766ddd3fa496e350561d7a306592b822e37b91450e2e3170b427fd84f07a04106fccf2cbf2a9527a288664fafd5de6d423eae3cd09e4a3ea314e5cd853231
+EBUILD numpy-2.0.0.ebuild 3302 BLAKE2B 3fef6c60c9c7869ac55b39695e7b657d9d49ed529aab0590da4453ec4446bd52eac56a95031f123025796b46e19640c6f5732e178b75b025cd21cb2eeba58afa SHA512 4d26cea15c6849ca9b8240e0ecdadea028315719238d2baf181be71b815286ddb3a9be21839fd4171046e24c1b193c27287e0764db33e7ea7b109420b99a10af
EBUILD numpy-2.0.0_rc2-r1.ebuild 3129 BLAKE2B 067a75ecc7ecea3ea603e0d9f9d80076d1d7d488aca0a6ae5714dc69c1acc362284637f36527cf50664adc2555ef4cd408feeed167e6adc6c655d02cfa195c34 SHA512 98e8d460abf6495cd88ae6878d4bca3f22e503103606d1b408a92a736e546a72299f5a3c3aa0224b27dd31ab61067ec215851fb2fa13333e10be803e3b374144
MISC metadata.xml 932 BLAKE2B 7a4af31f613bab05ff542da48bf6ff1484d9df2459f559516e71329451dd739d3df0fead507c8033d94ab9ed516b68efe7f21819a8cd6ca303643d8c8bc34e86 SHA512 32cb8c1ab61521a02cbec38f6ea383f074e50d46aa3462ddcb85710f9d348e8e628cf2a5725e3cd921cc32f02885a1b5f02125639f0ec885384eeeff7f468a06
diff --git a/dev-python/numpy/numpy-2.0.0.ebuild b/dev-python/numpy/numpy-2.0.0.ebuild
new file mode 100644
index 000000000000..600343fdf194
--- /dev/null
+++ b/dev-python/numpy/numpy-2.0.0.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 flag-o-matic fortran-2 pypi
+
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="
+ https://numpy.org/
+ https://github.com/numpy/numpy/
+ https://pypi.org/project/numpy/
+"
+
+LICENSE="BSD"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+# +lapack because the internal fallbacks are pretty slow. Building without blas
+# is barely supported anyway, see bug #914358.
+IUSE="+lapack"
+
+RDEPEND="
+ lapack? (
+ >=virtual/cblas-3.8
+ >=virtual/lapack-3.8
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-build/meson-1.1.0
+ >=dev-python/cython-3.0.6[${PYTHON_USEDEP}]
+ lapack? (
+ virtual/pkgconfig
+ )
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.14.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # bug #922457
+ filter-lto
+ # https://github.com/numpy/numpy/issues/25004
+ append-flags -fno-strict-aliasing
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ DISTUTILS_ARGS=(
+ -Dallow-noblas=$(usex !lapack true false)
+ -Dblas=$(usev lapack cblas)
+ -Dlapack=$(usev lapack lapack)
+ # TODO: cpu-* options
+ )
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Very disk-and-memory-hungry
+ lib/tests/test_io.py::TestSaveTxt::test_large_zip
+ lib/tests/test_io.py::TestSavezLoad::test_closing_fid
+ lib/tests/test_io.py::TestSavezLoad::test_closing_zipfile_after_load
+
+ # Precision problems
+ _core/tests/test_umath_accuracy.py::TestAccuracy::test_validate_transcendentals
+
+ # Runs the whole test suite recursively, that's just crazy
+ core/tests/test_mem_policy.py::test_new_policy
+
+ typing/tests/test_typing.py
+ # Uses huge amount of memory
+ core/tests/test_mem_overlap.py
+ 'core/tests/test_multiarray.py::TestDot::test_huge_vectordot[complex128]'
+ )
+
+ if [[ $(uname -m) == armv8l ]]; then
+ # Degenerate case of arm32 chroot on arm64, bug #774108
+ EPYTEST_DESELECT+=(
+ core/tests/test_cpu_features.py::Test_ARM_Features::test_features
+ )
+ fi
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ _core/tests/test_nditer.py::test_iter_refcount
+ _core/tests/test_limited_api.py::test_limited_api
+ f2py/tests/test_f2py2e.py::test_gh22819_cli
+ )
+ ;&
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # flaky
+ f2py/tests/test_crackfortran.py
+ f2py/tests/test_data.py::TestData::test_crackedlines
+ f2py/tests/test_data.py::TestDataF77::test_crackedlines
+ f2py/tests/test_f2py2e.py::test_gen_pyf
+ )
+ ;;
+ esac
+
+ if ! has_version -b "~${CATEGORY}/${P}[${PYTHON_USEDEP}]" ; then
+ # depends on importing numpy.random from system namespace
+ EPYTEST_DESELECT+=(
+ 'random/tests/test_extending.py::test_cython'
+ )
+ fi
+
+ rm -rf numpy || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs numpy
+}
+
+python_install_all() {
+ local DOCS=( LICENSE.txt README.md THANKS.txt )
+ distutils-r1_python_install_all
+}