summaryrefslogtreecommitdiff
path: root/dev-python/numpy/numpy-1.21.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/numpy/numpy-1.21.4.ebuild
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/numpy/numpy-1.21.4.ebuild')
-rw-r--r--dev-python/numpy/numpy-1.21.4.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-python/numpy/numpy-1.21.4.ebuild b/dev-python/numpy/numpy-1.21.4.ebuild
index cd54f4bc4a63..114e5f17f876 100644
--- a/dev-python/numpy/numpy-1.21.4.ebuild
+++ b/dev-python/numpy/numpy-1.21.4.ebuild
@@ -117,6 +117,14 @@ python_test() {
numpy/typing/tests/test_typing.py::test_reveal[arrayterator.py]
)
+ if use arm && [[ $(uname -m || echo "unknown") == "armv8l" ]] ; then
+ # Degenerate case. arm32 chroot on arm64.
+ # bug #774108
+ deselect+=(
+ numpy/core/tests/test_cpu_features.py::Test_ARM_Features::test_features
+ )
+ fi
+
distutils_install_for_testing --single-version-externally-managed \
--record "${TMPDIR}/record.txt" ${NUMPY_FCONFIG}