summaryrefslogtreecommitdiff
path: root/dev-python/numexpr/numexpr-2.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-python/numexpr/numexpr-2.8.4.ebuild
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-python/numexpr/numexpr-2.8.4.ebuild')
-rw-r--r--dev-python/numexpr/numexpr-2.8.4.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/numexpr/numexpr-2.8.4.ebuild b/dev-python/numexpr/numexpr-2.8.4.ebuild
deleted file mode 100644
index 5e14c17b6ffa..000000000000
--- a/dev-python/numexpr/numexpr-2.8.4.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="
- https://github.com/pydata/numexpr/
- https://pypi.org/project/numexpr/
-"
-SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
-
-DEPEND="
- >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
-"
-RDEPEND="
- ${DEPEND}
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-
-python_test() {
- pushd "${BUILD_DIR}/install/usr/lib/${EPYTHON}/site-packages" >/dev/null || die
- "${EPYTHON}" - <<-EOF || die "Tests failed with ${EPYTHON}"
- import sys,numexpr
- sys.exit(0 if numexpr.test().wasSuccessful() else 1)
- EOF
- pushd >/dev/null || die
-}