summaryrefslogtreecommitdiff
path: root/dev-python/nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-09 08:15:38 +0100
commit21616d4521c47fc859035ab3939842cddd56e374 (patch)
treebbe695483012ac54498cd55c2d9c03c67fef36d0 /dev-python/nuitka
parent3fd9d065ab109700e92fc1cea2a6519a39a5b007 (diff)
gentoo auto-resync : 09:08:2022 - 08:15:37
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/nuitka-0.9.5.ebuild49
-rw-r--r--dev-python/nuitka/nuitka-0.9.6.ebuild49
-rw-r--r--dev-python/nuitka/nuitka-1.0.ebuild49
3 files changed, 0 insertions, 147 deletions
diff --git a/dev-python/nuitka/nuitka-0.9.5.ebuild b/dev-python/nuitka/nuitka-0.9.5.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-0.9.5.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/nuitka/nuitka-0.9.6.ebuild b/dev-python/nuitka/nuitka-0.9.6.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-0.9.6.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}
diff --git a/dev-python/nuitka/nuitka-1.0.ebuild b/dev-python/nuitka/nuitka-1.0.ebuild
deleted file mode 100644
index 5b987e13729d..000000000000
--- a/dev-python/nuitka/nuitka-1.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 flag-o-matic optfeature
-
-DESCRIPTION="Python to native compiler"
-HOMEPAGE="https://www.nuitka.net"
-SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
-S="${WORKDIR}/${P^}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~loong ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
-BDEPEND="
- ${RDEPEND}
- test? ( dev-util/ccache )
-"
-
-DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
-
-distutils-r1_src_prepare() {
- # remove vendored version of SCons that is Python2 only
- # this should be removed when upstream removes support for Python2
- rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
- eapply_user
-}
-
-python_install() {
- distutils-r1_python_install
- doman doc/nuitka3.1 doc/nuitka3-run.1
-}
-
-python_test() {
- append-ldflags -Wl,--no-warn-search-mismatch
- ./tests/basics/run_all.py search || die
-}
-
-pkg_postinst() {
- optfeature "support for stand-alone executables" app-admin/chrpath
-}