summaryrefslogtreecommitdiff
path: root/dev-python/nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-27 12:48:57 +0100
commit70b82ae359a5538711e103b0e8dfb92654296644 (patch)
tree8412b84ff9ce02a22be5251052b00feefe1d5b70 /dev-python/nuitka
parent64e107b9b6058580ff0432107eb37cefb0b2a7d8 (diff)
gentoo resync : 27.10.2018
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest3
-rw-r--r--dev-python/nuitka/metadata.xml21
-rw-r--r--dev-python/nuitka/nuitka-0.6.0.4.ebuild29
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
new file mode 100644
index 000000000000..5ed371c6e7c3
--- /dev/null
+++ b/dev-python/nuitka/Manifest
@@ -0,0 +1,3 @@
+DIST Nuitka-0.6.0.4.tar.gz 2010373 BLAKE2B 96d31fde6d087bea81051bfcc208d52466b9c45785c2167c61721440fe930906958ee840bb98258c7c1b98c067302049afd63bbf5cfd422a69c1994675c29c70 SHA512 f9a30ad578b80679c0313be84150adff83a90b35c758487fc9f5240d527cf0a905b6257a0dfdf2a2c8c7322688108a6673c56238480344adce123d67416eb197
+EBUILD nuitka-0.6.0.4.ebuild 630 BLAKE2B 5526f072dba96751c9fa057829fedbe82dcf2a032ae2f6df815e54783a216d6d2a363b49f0e4b0f0b1627299e4f94ca79198b46e69830b3a0ef2a90afc2ec9ca SHA512 764095edacfea35fe8eed86c5588821895f49d3e2d7c7ca244661c7910e9e7796e1ebcef6ca31d1759c0ccdf433fece6944a5d003b644b1e0c88a55272ed9837
+MISC metadata.xml 750 BLAKE2B 56bff65b936301e2d0347e553a1ea85b89c4c991697f665b47b01dfd7e40b94726fca15c67e4387fb79ec19f77851e275bb80c48ded3f76e6cf4cb81d10ba90f SHA512 01ed4ef871d9d43ccb30b60e5051f513b56d7ab3eb46ad64b76e6ee8f53f0088c4a3d75227a0870e82664476954d6603f70614232735f107bb24a06702c014ab
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
new file mode 100644
index 000000000000..a082b06e69cd
--- /dev/null
+++ b/dev-python/nuitka/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+</maintainer>
+<maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+</maintainer>
+<longdescription lang="en">
+ Python compiler with full language support and CPython compatibility
+ This Python compiler achieves full language compatibility and compiles Python
+ code into compiled objects that are not second class at all. Instead they can
+ be used in the same way as pure Python objects.
+</longdescription>
+<upstream>
+ <remote-id type="github">pwman3/pwman3</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/nuitka/nuitka-0.6.0.4.ebuild b/dev-python/nuitka/nuitka-0.6.0.4.ebuild
new file mode 100644
index 000000000000..f90b09327492
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.0.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6)
+inherit distutils-r1
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="http://www.nuitka.net"
+SRC_URI="http://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ elog "nuitka needs app-admin/chrpath for building"
+ elog "stand-alone executables"
+}