summaryrefslogtreecommitdiff
path: root/dev-python/nuitka/nuitka-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /dev-python/nuitka/nuitka-0.6.2.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'dev-python/nuitka/nuitka-0.6.2.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-0.6.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-0.6.2.ebuild b/dev-python/nuitka/nuitka-0.6.2.ebuild
new file mode 100644
index 000000000000..306034cd1e10
--- /dev/null
+++ b/dev-python/nuitka/nuitka-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_5 python3_6 )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="${DEPEND}
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-util/scons[${PYTHON_USEDEP}]
+ "
+
+S="${WORKDIR}/${P^}"
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}