summaryrefslogtreecommitdiff
path: root/dev-python/nspektr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/nspektr
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/nspektr')
-rw-r--r--dev-python/nspektr/Manifest3
-rw-r--r--dev-python/nspektr/metadata.xml11
-rw-r--r--dev-python/nspektr/nspektr-0.3.0.ebuild66
3 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/nspektr/Manifest b/dev-python/nspektr/Manifest
new file mode 100644
index 000000000000..0e6a88ad844a
--- /dev/null
+++ b/dev-python/nspektr/Manifest
@@ -0,0 +1,3 @@
+DIST nspektr-0.3.0.tar.gz 6314 BLAKE2B cb7b9b5b35a455d4e72e78d93db49b4f8e274c7d7a6c8bf7ccca52cce2598a937d31b76f1a30c4aa6d673e4ce52c4645ce7392965df35b0888d1c69226e08f00 SHA512 6fc22ad7858858f3b956ba5918ca92468f13d4b7db0e4861b836e63153f7e4319c6468e4f73969ce3fb7845ca8d97808b9db2eb2705a47fe1a8c4c19b9c2ef33
+EBUILD nspektr-0.3.0.ebuild 1526 BLAKE2B 2ae674a51e64b58d2bb7f4beb462566158efd9276741eefedc22035b2b9465b9abc94df8749514e8c74fcb266c5fbe4d5634ba3a41f4b83d18b51123c378f739 SHA512 aa776765741a1deb663b1fec5630d856699afeac7cac28a7c068bf09b0f948d0ec7b0ad88164c68fb9f13a0626c71e100411bdf6b419039d628af2918faac8ab
+MISC metadata.xml 343 BLAKE2B c5ec4b6c1f41692875fcb9a93dea4c0f253339788b94fd667709898e2cc49470f113258137093fd29986ed8fbadf2ea64f95319c51568f12259b8869558bfdab SHA512 da052d5ee619430fbfc021b9eb8d3967dc4d6ca3ce0bc5c9b1badb067d7c0babe12abde3fbc9c4710bc6a0cf081e6bc445504b852ec714f819781e1c4780779a
diff --git a/dev-python/nspektr/metadata.xml b/dev-python/nspektr/metadata.xml
new file mode 100644
index 000000000000..8d6c012216d8
--- /dev/null
+++ b/dev-python/nspektr/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">jaraco/nspektr</remote-id>
+ <remote-id type="pypi">nspektr</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nspektr/nspektr-0.3.0.ebuild b/dev-python/nspektr/nspektr-0.3.0.ebuild
new file mode 100644
index 000000000000..1dfff8ffd725
--- /dev/null
+++ b/dev-python/nspektr/nspektr-0.3.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distribution package dependency inspector"
+HOMEPAGE="
+ https://github.com/jaraco/nspektr/
+ https://pypi.org/project/nspektr/
+"
+SRC_URI="
+ https://github.com/jaraco/nspektr/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~m68k ~ppc ~ppc64 ~sparc"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ test? (
+ dev-python/pip[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "nspektr"
+ version = "${PV}"
+ description = "package inspector"
+
+ # tests inspect itself
+ [project.optional-dependencies]
+ docs = [
+ "fake-nonexisting",
+ ]
+ testing = [
+ "pytest",
+ ]
+ EOF
+}