summaryrefslogtreecommitdiff
path: root/dev-python/nototools/nototools-0_pre20200207.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /dev-python/nototools/nototools-0_pre20200207.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'dev-python/nototools/nototools-0_pre20200207.ebuild')
-rw-r--r--dev-python/nototools/nototools-0_pre20200207.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/nototools/nototools-0_pre20200207.ebuild b/dev-python/nototools/nototools-0_pre20200207.ebuild
new file mode 100644
index 000000000000..d0fbe08354c2
--- /dev/null
+++ b/dev-python/nototools/nototools-0_pre20200207.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Noto fonts support tools and scripts plus web site generation"
+HOMEPAGE="https://github.com/googlei18n/nototools"
+
+COMMIT="9731cb825a5c7c7c88c043009f15d4d1e5708df1"
+SRC_URI="https://github.com/googlei18n/nototools/archive/${COMMIT}.tar.gz#/nototools-${COMMIT}.tar.gz"
+
+LICENSE="Apache-2.0 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-gfx/scour
+ >=dev-python/booleanOperations-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/defcon-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyclipper-1.0.6[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+python_test() {
+ esetup.py test
+}