summaryrefslogtreecommitdiff
path: root/dev-python/notify2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/notify2
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/Manifest1
-rw-r--r--dev-python/notify2/notify2-0.3.1-r2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
index 2f570119fbfd..dbc6ace57a4b 100644
--- a/dev-python/notify2/Manifest
+++ b/dev-python/notify2/Manifest
@@ -1,3 +1,4 @@
DIST notify2-0.3.1.tar.gz 17792 BLAKE2B 649df1934d1fffb97dabbf2f483204c55427fbede851840d642da2e4e62a9bda9d49670e60f5b2cda36b62ee47b7d0cd861d757d338867547dce3c7d61ddf7b4 SHA512 0b69a64e0a7e4955ee767c975db92c5c60d28c0e54f77498cfb98390771a8f536631fc34e42b5c46c138dfa1054b5516a0809b8e3b0cb9237a39825ddb827109
EBUILD notify2-0.3.1-r1.ebuild 738 BLAKE2B 1050c727ef34716a21e4dfeb36a9834de07e110e15c9b68c7b91a14616646a6dc604265f574c9363ad4c7f2e4bbe299a3f81fd2ec9d8f0863a188d70055bc7cf SHA512 a794212cf4033def159205a3b8d4d7b8bde31ee375eb14bb5ede368005f93415cb94a2fe3fc512b902e3338613007b44b674b5f0b89f129f01522084850530d3
+EBUILD notify2-0.3.1-r2.ebuild 735 BLAKE2B 16ec1d30655285131c94d550148fddc3ab004fd052ec6e28deed0509157b5cbfd34ddda4ee26e97b9a82511bf05b8747eb59b20a04a4a3067558ef19a2cf0f65 SHA512 b4a3839a0d37abdc67fa8c3942449a6ca750bd4251a83eb3d3f5f7ea7ff0823a2e924972c83a7a714277fb3a25aaff94d433120d0e7b856affcfd2e9169414f3
MISC metadata.xml 465 BLAKE2B 477ef3b148c7916372b0c12fc450dc9bacb59c609a3e3e005be6f8d5a268661405744c16180b336e34f4782f7e3a38ba17e63747d46199d0eb161e23d8415eaa SHA512 8024b5c580d09b74bf6a258dad507bec09d0c7bbbd10861bc2f866dd71acd7a858e7175dcb1d670cfdbade64da3f607667434a8587de6ceaeee7da028ce332ba
diff --git a/dev-python/notify2/notify2-0.3.1-r2.ebuild b/dev-python/notify2/notify2-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..1a165cade8b1
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+BDEPEND="test? ( sys-apps/dbus[X] )"
+
+python_test() {
+ virtx ${EPYTHON} test_notify2.py
+}
+
+python_install_all() {
+ if use examples; then
+ rm examples/notify2.py || die
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}