summaryrefslogtreecommitdiff
path: root/dev-python/notify-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/notify-python
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/notify-python')
-rw-r--r--dev-python/notify-python/Manifest4
-rw-r--r--dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch37
-rw-r--r--dev-python/notify-python/metadata.xml12
-rw-r--r--dev-python/notify-python/notify-python-0.1.1-r3.ebuild56
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/notify-python/Manifest b/dev-python/notify-python/Manifest
new file mode 100644
index 000000000000..f760eb95d7c8
--- /dev/null
+++ b/dev-python/notify-python/Manifest
@@ -0,0 +1,4 @@
+AUX notify-python-0.1.1-libnotify-0.7.patch 916 BLAKE2B 22fbcd4a8c1931fe78a342d5d82df71664f803d6eb935003c0f0e46bc7f562b10b038983744ba16b883db72895ad7f1ef57d9fadb3c9c6f93219b94aa47ce89e SHA512 1b8c1e315ecd842925335d2115a941df47569a9557e79eca734a051e838418d0fe0d315e4f8b41de219662271dbb6e1faa8398374d1728e92263c84feb0ccc66
+DIST notify-python-0.1.1.tar.bz2 214514 BLAKE2B 7e7496b817abedc5577751a6525ca928c6f7e8cc51aeac810a0927e46533d93d4da73b5f76846a68cde025dae24000601a5745eb93037b149177d4941cbdaffc SHA512 67021af81d77b6a1ead4ee2a0ab4e8684c2b60c672ab7aa09a8f89d71cf646453d9be76455ac28616d70645019946db1731a7021fbb91fe66d9e057fcb3815a0
+EBUILD notify-python-0.1.1-r3.ebuild 1293 BLAKE2B 630dd31c708934cbab75d046ac11d7ec5cccb7e70e4681d64b98a75b357a53a234142e17a3468deec0c6d4d34f3d3a59f60d2d846bc3f3ba27de87439e82aea4 SHA512 6bc2ca03dc06d55ae33e47d91213092596d5a40a449c2ba7a63512783afe7a5e7ad34caf406f5d389968d37fd550cfac6d9426e239958bc5621cbc3eb4ec8c25
+MISC metadata.xml 361 BLAKE2B 2e9dc3370e159928629b395032b496eb13316f2d46b6575d0f2c9617b4ef77333143fc744fd5b503bad412c8eb240aadc1ae40d5b05dc39d185118ebfc176419 SHA512 f752e04d417b93556d88c32272e0b53b94d09da233b3cd027713fd70a7552aa9ee5b5556bc26aa4cc33a1d333440318238bb7674a6f1172f14e0688e92c4ac9a
diff --git a/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch b/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..ee146cb6fd84
--- /dev/null
+++ b/dev-python/notify-python/files/notify-python-0.1.1-libnotify-0.7.patch
@@ -0,0 +1,37 @@
+http://pkgs.fedoraproject.org/gitweb/?p=notify-python.git;a=blob_plain;f=libnotify07.patch;hb=HEAD
+
+--- src/pynotify.defs
++++ src/pynotify.defs
+@@ -38,7 +38,6 @@
+ '("const-gchar*" "summary")
+ '("const-gchar*" "message" (null-ok) (default "NULL"))
+ '("const-gchar*" "icon" (null-ok) (default "NULL"))
+- '("GtkWidget*" "attach" (null-ok) (default "NULL"))
+ )
+ )
+
+@@ -53,24 +52,6 @@
+ )
+ )
+
+-(define-method attach_to_widget
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_widget")
+- (return-type "none")
+- (parameters
+- '("GtkWidget*" "attach")
+- )
+-)
+-
+-(define-method attach_to_status_icon
+- (of-object "NotifyNotification")
+- (c-name "notify_notification_attach_to_status_icon")
+- (return-type "none")
+- (parameters
+- '("GtkStatusIcon*" "attach")
+- )
+-)
+-
+ (define-method show
+ (of-object "NotifyNotification")
+ (c-name "notify_notification_show")
diff --git a/dev-python/notify-python/metadata.xml b/dev-python/notify-python/metadata.xml
new file mode 100644
index 000000000000..0f698c2b7126
--- /dev/null
+++ b/dev-python/notify-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/notify-python/notify-python-0.1.1-r3.ebuild b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
new file mode 100644
index 000000000000..c61a789aabd8
--- /dev/null
+++ b/dev-python/notify-python/notify-python-0.1.1-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils eutils python-r1
+
+DESCRIPTION="Python bindings for libnotify"
+HOMEPAGE="http://www.galago-project.org/"
+SRC_URI="http://www.galago-project.org/files/releases/source/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-python/pygtk-2.24:2[${PYTHON_USEDEP}]
+ >=x11-libs/libnotify-0.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-libnotify-0.7.patch )
+
+src_prepare() {
+ # Remove the old pynotify.c to ensure it's properly regenerated #212128.
+ rm -f src/pynotify.c || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl autotools-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+ prune_libtool_files --all
+
+ # Requested from bug 351879.
+ if use examples; then
+ docinto examples
+ dodoc tests/*.{png,py}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}