summaryrefslogtreecommitdiff
path: root/dev-python/notebook
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /dev-python/notebook
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'dev-python/notebook')
-rw-r--r--dev-python/notebook/Manifest1
-rw-r--r--dev-python/notebook/notebook-6.1.3-r1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/notebook/Manifest b/dev-python/notebook/Manifest
index dd85724d460e..dac19f35ba6f 100644
--- a/dev-python/notebook/Manifest
+++ b/dev-python/notebook/Manifest
@@ -5,5 +5,6 @@ AUX notebook-6.0.3-py39.patch 4042 BLAKE2B c15f7e4779cc6ccc20f837bf7867eb4ced353
DIST notebook-6.0.3.tar.gz 14048151 BLAKE2B ad4e433accc90acc13efc8005146dd8bcf2e645c104473f0e71d8d9fab80d7e128eb4e070b8aa04aee77e0d6115499e61beb841d94cf66b0e098dc50d3916cbd SHA512 fb56d0e10da3f8673e9578cdf04759dc3247547af6be4f479e9b183f3c5bd0a891fbfede187e0f5aca5c6ffdb9cae6ada23fe6dd159aca2d9cdf967f1f150922
DIST notebook-6.1.3.tar.gz 13806042 BLAKE2B da63fdabd1a71e4247a9e340539e688410a84c58d94049dfb7e8e3fcdc53686a55eb855687df34ff48f599a0c5aececbd9a8e1aa1d2ff7baa2a6da1b4e1bcf24 SHA512 67a8feb01dfb665bb24f3ce1b28212e9bad5a188e8cef1d168c4edaf207cbc16d516f6024ca905f75f1c27ba4890da858c5278a3ee84a4c4ac1bdbf225afa351
EBUILD notebook-6.0.3.ebuild 2369 BLAKE2B 89ebccda62bf6c1597dd015ed76fc9cf407bc3749a013c5762a530844528288bb8193c9454f604be02791b3d349227661dac899fee2030a250bcc558867e39c2 SHA512 7c17a5b0124fb1dc6af18cb9736793ea3a9b3e5b9179e64c7cd60311b1762e5339d4ac5c023d433bc57c2abd6bec5cbf65b91e167300ce139583e0ad7a33beb4
+EBUILD notebook-6.1.3-r1.ebuild 2589 BLAKE2B ba41ae96b619b3d1348c24604dfcd215cc25f89bd8c88b2fd76c9760295f09d7ccc88910726df55d614e30a7828c02f199dbfd268277bd1decbda8b581db5a1d SHA512 293d8e2ab1e28729414f9b7acb9af2198cc74ae18317722eaaf54338123e0bb8ade5e4ea38c1e02467db77c757a80e35ae2ec1b94b896f02603f0346c069fba2
EBUILD notebook-6.1.3.ebuild 2589 BLAKE2B 111e1f31138241640409c8e08aabe188bed91c14d73c4962f021cc55e2cb015eb0638d10426bf63df30dfe935d6a84a9e04f1d3d416694abead8af75d616f1d9 SHA512 a26da170b99ab62deac489455a4139d04086bb525eb62c70f529f5063d4fb30a3d860a28bc3ce01015c16f5eb874bf542a850062bda1039df517331ee9933628
MISC metadata.xml 441 BLAKE2B f744bd6821b3c38aaaff373d5e44b8b84d35bb50a58e1fb6515cc580727a29240a2394c0d6a0c846dd76062905a8de7d75faf96ddb0b23a0bc05b24875918013 SHA512 4f59ae02210d5df4c6416cdec8d85931577e931e885fe7807967ff708a7c5436fe246e152f060e99b0ada2665e8a0321bd4382640680a892ad514b16926351f7
diff --git a/dev-python/notebook/notebook-6.1.3-r1.ebuild b/dev-python/notebook/notebook-6.1.3-r1.ebuild
new file mode 100644
index 000000000000..2f974c926f26
--- /dev/null
+++ b/dev-python/notebook/notebook-6.1.3-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-libs/mathjax-2.4
+ dev-python/argon2-cffi[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/terminado-0.8.3[${PYTHON_USEDEP}]
+ >=www-servers/tornado-5.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.6.1[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-5.3.4[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/send2trash[${PYTHON_USEDEP}]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]"
+
+# sphinx 2+ seems to have a problem with its github plugin. temporarily adding
+# a version constraint.
+BDEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-5.7.0-no-mathjax.patch
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # disable bundled mathjax
+ sed -i 's/^.*MathJax.*$//' bower.json || die
+
+ # require geckodriver
+ rm -r notebook/tests/selenium || die
+ # trash doesn't seem to work for us
+ sed -e 's:test_delete:_&:' \
+ -i notebook/services/contents/tests/test_manager.py || die
+ sed -e 's:test_checkpoints_follow_file:_&:' \
+ -e 's:test_delete:_&:' \
+ -i notebook/services/contents/tests/test_contents_api.py || die
+ # network-sandbox?
+ sed -e 's:test_connections:_&:' \
+ -e 's:test_culling:_&:' \
+ -i notebook/services/kernels/tests/test_kernels_api.py || die
+
+ sed -i -e "/'bdist_egg':/d" setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ local -x PATH=${TEST_DIR}/scripts:${PATH}
+ pytest -vv || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ ln -sf \
+ "${EPREFIX}/usr/share/mathjax" \
+ "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_preinst() {
+ # remove old mathjax folder if present
+ rm -rf "${EROOT}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
+}