summaryrefslogtreecommitdiff
path: root/dev-python/notebook/notebook-7.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-05 09:19:42 +0100
commita14be3350a832e70959d0b2386bc43c3b95f82e1 (patch)
treea0bd34e3c1e8ca9489d08f257a5f29171d4bfe7f /dev-python/notebook/notebook-7.0.2.ebuild
parent9d86a2177f8ea7e726ba388e4ee28007def4d4ac (diff)
gentoo auto-resync : 05:08:2023 - 09:19:42
Diffstat (limited to 'dev-python/notebook/notebook-7.0.2.ebuild')
-rw-r--r--dev-python/notebook/notebook-7.0.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/notebook/notebook-7.0.2.ebuild b/dev-python/notebook/notebook-7.0.2.ebuild
new file mode 100644
index 000000000000..f59b40994b79
--- /dev/null
+++ b/dev-python/notebook/notebook-7.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi xdg-utils
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/jupyter-server-2.4.0[${PYTHON_USEDEP}]
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4.0.2[${PYTHON_USEDEP}]
+ <dev-python/jupyterlab-5[${PYTHON_USEDEP}]
+ >=dev-python/notebook-shim-0.2[${PYTHON_USEDEP}]
+ <dev-python/notebook-shim-0.3[${PYTHON_USEDEP}]
+ >=dev-python/tornado-6.2.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/nbval[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-unixsocket[${PYTHON_USEDEP}]
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}