summaryrefslogtreecommitdiff
path: root/dev-python/nose_warnings_filters
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/nose_warnings_filters
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/nose_warnings_filters')
-rw-r--r--dev-python/nose_warnings_filters/Manifest3
-rw-r--r--dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch13
-rw-r--r--dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild4
3 files changed, 19 insertions, 1 deletions
diff --git a/dev-python/nose_warnings_filters/Manifest b/dev-python/nose_warnings_filters/Manifest
index 54b1c0a19006..b80b3177e290 100644
--- a/dev-python/nose_warnings_filters/Manifest
+++ b/dev-python/nose_warnings_filters/Manifest
@@ -1,3 +1,4 @@
+AUX nose_warnings_filters-0.1.5-setuptools-newline-desc.patch 2308 BLAKE2B 96d144e3c393c89320e6417738672dcd6c59ceb1e99aafcbc104305baa370e6210c7d0ab454c5de3944dd0986de599e39453985364ea48846cfb6f7aabd4f52e SHA512 95530c1220e57388e8f4c998ba69f77e68e9b805c92eaa87cac82b1e75ec767b926a056f382ba2431474d26142259c248841ce4ea260000738551e8f16dea3aa
DIST nose_warnings_filters-0.1.5.tar.gz 3895 BLAKE2B 90fe9d0255227159cb4465648f45aa33623bf31b2182a7579d2f7f17687a832b2c96e9c2b3f0b5c477d808907d92bc8567d2aeed6bd13dcd28878394e9726fb6 SHA512 7ada463840bb2e3a1c7e357c231f9c7d4c7ce9f24fe7fe1e33404df41711663c8232001f9a258898f49ce89bb542a942240cf7312ee41bc75f86ca2015378405
-EBUILD nose_warnings_filters-0.1.5-r3.ebuild 522 BLAKE2B 90cdfe4d76db9ecdcd75aebcd23dd16875fa8e80ab1114a1574945bfcead1f988c7423dc1919f6b5a04ced3a56865ee4e86e9bd1c0be6059427188d77954bfee SHA512 11287e7c8c7fcf2cf3e9f36a888aa8c54abdce85651a7ea3dd7c7d6ba231dc3040a6269a9088fe7a8ded0d50e2048d3975583e14e5aae7a2d6cca9c8b77d6368
+EBUILD nose_warnings_filters-0.1.5-r3.ebuild 592 BLAKE2B ad5df0e97ac0f9fd7da4d337d7d1391e4512682535d8eedb4656c3bde24c17d8b932b82abddcb3cef0e09ebd6c545be9e68110b54ec077011b0c4de3c1989fbb SHA512 10a807e06e62fe8355ef590a60b38f029158368759ee033582fcfe292d1617d4776da5075f01ae9f595a33bda5d88985906a21b3c675ca31a0a5ccaf618cd9bd
MISC metadata.xml 394 BLAKE2B c0690d3854412fb367fa7108883bf0d04fb79ffb895aa95d0e3b40d6cc469b3b07f2e338ba6b3a96323fdbc8524da4f2c10864b5dee00d4c8f1c26b7909192a0 SHA512 5d639f6a0f739af70b1b93f65434e87b498ee89caeb527aaa7515d81d51d5cd3d03ae53432b8c4a444bf13a39e99f812762f28f59137dc5bf1f27710555a40b5
diff --git a/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch b/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch
new file mode 100644
index 000000000000..de05a2f5d26b
--- /dev/null
+++ b/dev-python/nose_warnings_filters/files/nose_warnings_filters-0.1.5-setuptools-newline-desc.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 1f9ac02..829c5e8 100644
+--- a/setup.py
++++ b/setup.py
+@@ -17,7 +17,7 @@ from setuptools import setup
+
+ setup(name='nose_warnings_filters',
+ version='0.1.5',
+- description='Allow to inject warning filters during ``nosetest``.\n\nPut the same arguments as ``warnings.filterwarnings`` in ``setup.cfg``\nat the root of your project. Separated each argument by pipes ``|``, one\nfilter per line. Whitespace are stripped.\n\nfor example:\n\n::\n\n [nosetests]\n warningfilters=default |.* |DeprecationWarning |notebook.*\n ignore |.*metadata.* |DeprecationWarning |notebook.*\n once |.*schema.* |UserWarning |nbfor.*\n error |.*warn.* |DeprecationWarning |notebook.services.contents.manager*\n\nIf you prefer another name for the configuration file, you can tell nose\nto load the configuration using the ``-c`` flag: run the tests with\n``nosetests -c nose.cfg``.\n\ndetails configuration.\n======================\n\nEach line of warning filter is separated in maximum 4 sections, that\nmatch the first 4 sections of ``filterwarnings``:\n\n.. code:: python\n\n filterwarnings(action, message="", category=Warning, module="", lineno=0, append=False)\n\nfields 2 to 4 can be omitted, ie to say 1 line can be of the following\nform:\n\n::\n\n action\n action| message\n action| message | category\n action| message | category | module\n\nthe value of each fields is treated the same as for ``filterwarnigns``\nexcept: - whitespace are trimmed. - if the ``category`` has dots, the\ncorresponding class try to be imported. If it does not have dots, the\nname is looked up in ``builtins`` or ``__builtins__``\n\ntest are failing\n================\n\nFor some reasons in some systems tests are failing; it seem that this\npackage have difficulty to self-test. That\'s likely due to the fact that\nthe tested package need to be in different namespaces, and by\nself-testing we break this assumption.\n',
++ description='Allow to inject warning filters during ``nosetest``',
+ url='https://github.com/Carreau/nose_warnings_filters',
+ author='Matthias Bussonnier',
+ author_email='bussonniermatthias@gmail.com',
diff --git a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
index 46d14c80fd80..eca1dd453d80 100644
--- a/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
+++ b/dev-python/nose_warnings_filters/nose_warnings_filters-0.1.5-r3.ebuild
@@ -16,4 +16,8 @@ KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.5-setuptools-newline-desc.patch
+)
+
distutils_enable_tests nose