summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/nose
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/Manifest3
-rw-r--r--dev-python/nose/nose-1.3.7_p20211111_p1-r1.ebuild58
-rw-r--r--dev-python/nose/nose-1.3.7_p20211111_p1.ebuild4
3 files changed, 62 insertions, 3 deletions
diff --git a/dev-python/nose/Manifest b/dev-python/nose/Manifest
index 813aa8d4d7e9..fb7756752433 100644
--- a/dev-python/nose/Manifest
+++ b/dev-python/nose/Manifest
@@ -1,3 +1,4 @@
DIST nose-1.3.7_p20211111_p1.gh.tar.gz 327855 BLAKE2B acddcaa0718f23f281ea34a977354b3ef88c95d4ef712afd8354effe6df7883d473b50caaa3b5c79fcc4c36a9d45bee4eb5865a6ef66e371dae12ed1a0a0418a SHA512 752eb1337fd481a1b8498ead330d716cf4180c18faabde257e9a1139928b9fa38e2e145d36c1ea8e3867a36d4843134ee26e9e9f83ff84d21f0fe246d2392d15
-EBUILD nose-1.3.7_p20211111_p1.ebuild 1427 BLAKE2B 8b821d64318e5b5c6b8147e359f5240bc9208bd41c919260b090b8f6376a3e2d62c54c32d42f1b8d28c726a77e0e5acd5cb47acb8dafcc67789372d5d237aaf6 SHA512 ab90f9cffc8235bae080ebc16989677b8131152b0f6ca1c252529aa243db3f8107e832ef962f1a9aa45b81119aaeedbc6ea904c3c768f61d829500bb4dff11bb
+EBUILD nose-1.3.7_p20211111_p1-r1.ebuild 1493 BLAKE2B 20ddccc792a0247665a9b9a5228b97dabdb09cf048274c7b12f352b28b2b09cc76ff15f10a9a15cfc3c0064c0d37b53ac9ca2571277fafd3954a82da7e5515ff SHA512 f161ff5c507ec06f08393428357015fedb1da8e5c88a45fc4e75562661cc34d8ba9c59037bedf6f13e43d2b2603c94ee4f5e97749a070e5ab985a6c46c69260c
+EBUILD nose-1.3.7_p20211111_p1.ebuild 1434 BLAKE2B 8e669f8fff66a8f211e35dfdd0f8b7737af59bf5cd98e15c2926f5478a280ddb1fa2c8d37d324c60a58105ca98b4d391f4358ab04a60582c09920d99451b3157 SHA512 cac7a9b25fe42092f7f3262bb6b1d86abd220a1d9b2fe834a516fb746082aaabf4311550e7ec58af1c1cef9ef53bb7f04e7e043f16728bfcc743b23bfafe564d
MISC metadata.xml 399 BLAKE2B bccd250e005dc4b4921b8affffa56c918069576663c44671189d40dea344c0fb880fcf41656b1c9c5043cea9a0203b3ad3b980f7920ecebab82b4c71f75214d4 SHA512 15fd9ea9d0c09833f25497e2715a15cb2b2dbcbe042e0a3fa24525455eaeb470d6c799fddcd635a5197c984252649a26352713fcd069123fe2546edc20566fa6
diff --git a/dev-python/nose/nose-1.3.7_p20211111_p1-r1.ebuild b/dev-python/nose/nose-1.3.7_p20211111_p1-r1.ebuild
new file mode 100644
index 000000000000..1722ad8f50c1
--- /dev/null
+++ b/dev-python/nose/nose-1.3.7_p20211111_p1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+EGIT_COMMIT="94fd6746619ee8728f2b8740ebf2d1582b03cb15"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+ https://pypi.org/project/nose/
+ https://nose.readthedocs.io/en/latest/
+ https://github.com/nose-devs/nose
+"
+SRC_URI="
+ https://github.com/arthurzam/nose/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
+ ' python3_{8..10} pypy3)
+ $(python_gen_cond_dep '
+ dev-python/twisted[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+
+src_prepare() {
+ # failing to find configuration file
+ sed -e 's/test_cover_options_config_file/_&/' \
+ -i unit_tests/test_cover_plugin.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m nose -v -a "!network" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc -r examples
+}
diff --git a/dev-python/nose/nose-1.3.7_p20211111_p1.ebuild b/dev-python/nose/nose-1.3.7_p20211111_p1.ebuild
index 08ed5c46c31d..0bcccaee3d86 100644
--- a/dev-python/nose/nose-1.3.7_p20211111_p1.ebuild
+++ b/dev-python/nose/nose-1.3.7_p20211111_p1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,7 @@ S="${WORKDIR}/${PN}-${COMMIT}"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="examples test"
RESTRICT="!test? ( test )"