summaryrefslogtreecommitdiff
path: root/dev-python/nose2/nose2-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-29 06:57:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-29 06:57:38 +0000
commit16fa78787149cbbd73549c6bcda0eec50293ea0e (patch)
treeb560d55335e6244a9974ef2f49a10fa3b7ecdf9a /dev-python/nose2/nose2-0.14.1.ebuild
parenteecd75a62239257eb2235bfe8697c73887a9a080 (diff)
gentoo auto-resync : 29:01:2024 - 06:57:37
Diffstat (limited to 'dev-python/nose2/nose2-0.14.1.ebuild')
-rw-r--r--dev-python/nose2/nose2-0.14.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/nose2/nose2-0.14.1.ebuild b/dev-python/nose2/nose2-0.14.1.ebuild
new file mode 100644
index 000000000000..db1432fea4e8
--- /dev/null
+++ b/dev-python/nose2/nose2-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+SRC_URI="
+ https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}