summaryrefslogtreecommitdiff
path: root/dev-python/nose2/nose2-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-30 11:17:10 +0100
commit200338d9ebd0cd0599af59f208eb58f48f5ae168 (patch)
tree03aa7ba96612219b7aeb018639ba95924c0f1d81 /dev-python/nose2/nose2-0.13.0.ebuild
parenta9a8100d7a659b808e3a112a113b65e16f0070c3 (diff)
gentoo auto-resync : 30:04:2023 - 11:17:09
Diffstat (limited to 'dev-python/nose2/nose2-0.13.0.ebuild')
-rw-r--r--dev-python/nose2/nose2-0.13.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/nose2/nose2-0.13.0.ebuild b/dev-python/nose2/nose2-0.13.0.ebuild
new file mode 100644
index 000000000000..c81ddcf8635d
--- /dev/null
+++ b/dev-python/nose2/nose2-0.13.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest with plugins"
+HOMEPAGE="
+ https://github.com/nose-devs/nose2/
+ https://pypi.org/project/nose2/
+"
+SRC_URI="
+ https://github.com/nose-devs/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/coverage-4.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinx-issues
+
+python_test() {
+ "${EPYTHON}" -m nose2.__main__ -vv || die "tests failed under ${EPYTHON}"
+}