summaryrefslogtreecommitdiff
path: root/dev-python/nose-random
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/nose-random
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/nose-random')
-rw-r--r--dev-python/nose-random/Manifest3
-rw-r--r--dev-python/nose-random/metadata.xml11
-rw-r--r--dev-python/nose-random/nose-random-1.0.0.ebuild20
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/nose-random/Manifest b/dev-python/nose-random/Manifest
new file mode 100644
index 000000000000..c5d97d5d4928
--- /dev/null
+++ b/dev-python/nose-random/Manifest
@@ -0,0 +1,3 @@
+DIST nose-random-1.0.0.tar.gz 3776 BLAKE2B 18dc40b13fcb970c4d2edeb6be9c6f3e710b36d14dcdc4a56c6e3ecf811ab2acd6be3e1c1cea2231eb5dc10581c77f201220354c77f3d9f67d89d894ed8b4f24 SHA512 9c62413fb00c3b774954ae7a65b08b122ae0dd2b24377efba8de345597b4ce4952aad09a0c2fea7f9d92f57a3664908fccd6eabadf32074a35978c958ea2b66f
+EBUILD nose-random-1.0.0.ebuild 498 BLAKE2B 5e24800b431e86c980b99f3ece5af4c8e4eb1755888a7a73df55bc33732677d032a1dd1556aaba48af2354e4fbf66f97d68abab3022c2b6fcb920b8848763785 SHA512 e94fbaa83f1dede642a02d11421d8f022f7112d2f9541c88897b202d5a9d610b95fb61a363d3b80a19ce390dc19f4ac5b64cf79739bf714a8016e9fd7f2cef56
+MISC metadata.xml 338 BLAKE2B e8be381e5e42a081be3637b77a9b5356dd7d74d0352976badfca62bdf7b65c04554552703b3e12e169ec1c4b57d07cedcf75387a0fd65a8177213f0de8bffa9c SHA512 b3e03151085bcaa51e2108d7e69042523148aaba924415421323d53005c1d047103827ed99bf064cda4f02cc313b3ff4e5fc681bccb5f1f23a82b40a744ed9bc
diff --git a/dev-python/nose-random/metadata.xml b/dev-python/nose-random/metadata.xml
new file mode 100644
index 000000000000..2541628cf9a8
--- /dev/null
+++ b/dev-python/nose-random/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/nose-random/nose-random-1.0.0.ebuild b/dev-python/nose-random/nose-random-1.0.0.ebuild
new file mode 100644
index 000000000000..c4a593c95802
--- /dev/null
+++ b/dev-python/nose-random/nose-random-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to facilitate randomized unit testing"
+HOMEPAGE="https://github.com/fzumstein/nose-random"
+SRC_URI="https://github.com/fzumstein/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+
+# no tests