summaryrefslogtreecommitdiff
path: root/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 03:07:48 +0100
commit5923f7107d7596f9ecb6a86b451105462668601c (patch)
tree57ebb2966a1787500108baf49e27b002aaaed0ce /dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
parent633591ecdf876d163972f90145c0ca61e6c496fa (diff)
gentoo auto-resync : 26:05:2023 - 03:07:47
Diffstat (limited to 'dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild')
-rw-r--r--dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
new file mode 100644
index 000000000000..e564c8306957
--- /dev/null
+++ b/dev-python/noiseprotocol/noiseprotocol-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Implementation of Noise Protocol Framework. Compatible with revisions 32 and 33."
+HOMEPAGE="https://pypi.org/project/noiseprotocol"
+SRC_URI="https://github.com/plizonczyk/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ rm -r "examples" || die "rm failed"
+}