summaryrefslogtreecommitdiff
path: root/dev-python/nltk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nltk
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/Manifest5
-rw-r--r--dev-python/nltk/metadata.xml16
-rw-r--r--dev-python/nltk/nltk-3.2.3.ebuild31
-rw-r--r--dev-python/nltk/nltk-3.2.5.ebuild31
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/nltk/Manifest b/dev-python/nltk/Manifest
new file mode 100644
index 000000000000..5bb558723539
--- /dev/null
+++ b/dev-python/nltk/Manifest
@@ -0,0 +1,5 @@
+DIST nltk-3.2.3.tar.gz 1166282 BLAKE2B 803dc1a8ec80a17538c2164d5ee0eca201be2307bbf3e08093a55cee93e9a539d8b48ea42c8ad84b540922355bf0b151ae04338d8505378a89173159d7464b76 SHA512 2e5c0899c29f61166b2e161e62e81fd35e045bda979fbfa662bf9ad1349be4aae6aabe4b9de34905e2abbc05b06a096480829fd66638efa35cd5c866f76c62e8
+DIST nltk-3.2.5.tar.gz 1188856 BLAKE2B 316e5955d2f90c351673ee9d3f0cc159babbcae08104518db62e796b422dcbf51668001b06b5d5dc399613d4db0ed39ff7dd15ad15d6f6c64e10c73a4d53bc06 SHA512 967b209ce3dde5296dafac16b91bff3894ff1a3f073c76974fd9193912597c82d2d1c50d4419052da77ab66f798f230f725b83f31368a95cacf94d46e45055de
+EBUILD nltk-3.2.3.ebuild 828 BLAKE2B 744fda1f9c31b67668244d273fb45f3e65545150ebe2eb258025c8a41e5746cfc6022f5181342a089a8bce72cc1e15b6a3b04c45483a8781bb3e0454c67d1cc2 SHA512 1f12ec98511728139858cb1c8a5519630ae85e070178cb756751a87711d0843ee91ce9551509a9812072b06125adc17a694fb8cf456f936d0173ff4e1ceeef8c
+EBUILD nltk-3.2.5.ebuild 830 BLAKE2B 592fb72c60a801700fc4a1710caca9ecaf6e3b5c70ba9e71935aff06507f43cfe15c71c4855122357524d04fe389db0457459819864c4b83a0ef6188e1a0fba7 SHA512 c25333641e987f8df21265efc97f50d0d7c6abb350352be31fb72339994cb0d0e68040d1b6ba856f54dad2888b44a71a63956b0c89b2e475cc998f128611f55e
+MISC metadata.xml 455 BLAKE2B f7f64dd6f4755438db233c712dbde5cc3aae6f2cd154c207bbef0196569b458a8d26c35b92601e8e79af4cfee7f4f57029d9a892677c477a86bbd8c78fa1da16 SHA512 315f7c1822be51c6fc541323f0b977dc0bb60e129a6bd907cd47ac1247c88e906b3452f2ded4d2071c142fd1d710c674039c95036124177744ad68ecc5ca4bd8
diff --git a/dev-python/nltk/metadata.xml b/dev-python/nltk/metadata.xml
new file mode 100644
index 000000000000..4bca3859ebd0
--- /dev/null
+++ b/dev-python/nltk/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <use>
+ <flag name="numpy">Use numpy for the saved word tokenizer</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">nltk</remote-id>
+ <remote-id type="pypi">nltk</remote-id>
+ </upstream>
+</pkgmetadata>
+
diff --git a/dev-python/nltk/nltk-3.2.3.ebuild b/dev-python/nltk/nltk-3.2.3.ebuild
new file mode 100644
index 000000000000..7c9c2a8c4acc
--- /dev/null
+++ b/dev-python/nltk/nltk-3.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy test tk"
+
+RDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# currently requires linguistic data to be downloaded separately
+RESTRICT="test"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/nltk/nltk-3.2.5.ebuild b/dev-python/nltk/nltk-3.2.5.ebuild
new file mode 100644
index 000000000000..00df16dee538
--- /dev/null
+++ b/dev-python/nltk/nltk-3.2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="http://nltk.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="numpy test tk"
+
+RDEPEND="numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+# currently requires linguistic data to be downloaded separately
+RESTRICT="test"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}