summaryrefslogtreecommitdiff
path: root/dev-python/nltk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/nltk
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/Manifest2
-rw-r--r--dev-python/nltk/nltk-3.6.3.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/nltk/Manifest b/dev-python/nltk/Manifest
index 4c6e1555cf47..00e1b056bbfa 100644
--- a/dev-python/nltk/Manifest
+++ b/dev-python/nltk/Manifest
@@ -1,4 +1,6 @@
AUX nltk-3.6.2-metadata.patch 1166 BLAKE2B b87a79ec16da57add95b83857c285a1d3e4907b90e9a430750f2189579b9531d1d455837506f99251468a6b53a250e5d6ed1da298cffd1805f4818d7d303bc5d SHA512 d382da1e8cee0eef56c5e85bb4a57b7ee4f150a4f42043977351b940653eddec55e67d9c404b282f7591170a7f970648b496c88d383073f8b218fdd97323f121
DIST nltk-3.6.2.tar.gz 2819833 BLAKE2B 9796822c35c524432e9790d0890b4388fbaa85b659e5415037422a22e8edbaf20775196b4416f441d62592b387066de9f7741b988c0d463349fc5c906bfd75b2 SHA512 3fd2cba52377613f35f6574f859482de987f969cfc8d4243a859be365ab1bd8300f9013dcedc6caeff7aa7fc035b331a47b557027209ca9a85b0cc7fbde44d6d
+DIST nltk-3.6.3.tar.gz 2824924 BLAKE2B fcab6647f43f4bf139857e9f4202aee688f564851976ed6a183e47361451fae771318346724e41f198b82cebdd5a47f151aaf932099143ef6faa2a77430fbfb4 SHA512 fe7244967df018670501304d1a8aa50a0f4d42bb0c73cc5e202eeab6a0f5da1eaed9b961f6026e3b8ae4b0393d788bcb58b263ba22a3ce6f5644022736035f98
EBUILD nltk-3.6.2-r1.ebuild 1634 BLAKE2B 85e25a760e7c94b0b4cf463d7ab89eb34a7d235a984dbed139da6cc0f151449f670a46edd3831e7866c16a37aa3fd569aac82317ec5b07bea00712f35c83038c SHA512 02a73f3ec7e43072b6200f9b65e28a1bbdc63efa23ee79508c8eb3caa25aa7f265562561ae54bf9e35dcc92e52ba98b698e89f82303949da016186c1fafb9602
+EBUILD nltk-3.6.3.ebuild 1588 BLAKE2B 8f84fa992e8b0c66338d34f070525b0dffb12ee67db46afee7f15e9816bbf543f1545e011b033baca9b21b162d2b1a11d7b9377fd638a92810d899657f51d53d SHA512 a56930b8055184d820bdbcd2a3bcdbe056957d9707319b31b0282514471a41ca539e406da318001b647e2b50daa1ed075eeacee529270c58969ee9570522f0b3
MISC metadata.xml 430 BLAKE2B 9c67c091a126c4af98c56de2d8227c1da65fbfad00671825642daefa117d711475b804bd90d72345e43d519a9219e195c1de1579dd6d60f6663c9813fc9c0d81 SHA512 5707c61031544a51e298d9c4c70685011f06b9d65c2370ecba6ecc23491c92fcc30988b6c0c28cb16f21eddebe412fff978a8f9661e5e95b9cff249f81420018
diff --git a/dev-python/nltk/nltk-3.6.3.ebuild b/dev-python/nltk/nltk-3.6.3.ebuild
new file mode 100644
index 000000000000..11dd1a3283d2
--- /dev/null
+++ b/dev-python/nltk/nltk-3.6.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+HOMEPAGE="https://www.nltk.org/ https://github.com/nltk/nltk/"
+SRC_URI="https://github.com/nltk/nltk/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="tk"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ >=dev-python/nltk-data-20200312-r1
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twython[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )"
+PDEPEND="dev-python/nltk-data"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # requires unpackaged pycrfsuite
+ sed -i -e '/>>>/s@$@ # doctest: +SKIP@' nltk/tag/crf.py || die
+ # replace fetching from network with duplicate file URL
+ sed -e 's@https://raw.githubusercontent.com/nltk/nltk/develop/nltk/test/toy.cfg@nltk:grammars/sample_grammars/toy.cfg@' \
+ -i nltk/test/data.doctest || die
+ # requires X and hangs in Xvfb
+ sed -e 's:test_plot:_&:' \
+ -i nltk/test/unit/test_cfd_mutation.py || die
+
+ distutils-r1_src_prepare
+}
+
+src_test() {
+ cd nltk/test || die
+ distutils-r1_src_test
+}