summaryrefslogtreecommitdiff
path: root/dev-python/networkx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-28 22:35:05 +0100
commit5c0cc325922d72d6e614def2a9b36ee95a46d2c1 (patch)
tree2734b6847fc660dd18cfcf5f839e14aad0188ad0 /dev-python/networkx
parent35a2663a10c1124ae2951397ed2a4435dc5808e5 (diff)
gentoo auto-resync : 28:10:2023 - 22:35:05
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest2
-rw-r--r--dev-python/networkx/networkx-3.2.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index b438874a850e..8cf4c06c6dd4 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1,5 +1,7 @@
DIST networkx-3.1.tar.gz 2021691 BLAKE2B 002bb00034e06a45298716c86fec4462efe8db8d206e8263d2e4ce0becc9c073aa2856e0c2df2e74d53237be0b02752204c7e387651aa45387781c383dd1f190 SHA512 9d75ecd25020f83c650824e9449e1c53004c13089dccf7424b65787144dfe3d2f638fd5aca1c4a792b165598b44644fda45bf54c49b3af278ddec5e1f669c38e
+DIST networkx-3.2.1.tar.gz 2073928 BLAKE2B fc4a4c0357f25cb3e4bfdfb38ffa528eddba22abc852bc80e0a70047aea2e401b0003c01108435ced1eacdba33d181395e73fcfa20773faa566c8b5cb45f6cdb SHA512 579c54a4a016617f5260df01b821c3906c4f289e80ae7bd618c0ebb9e05ebe806e71f1f660e3012531d04572ac4e6670aa73117ed26da8248fbb8ef7228b5803
DIST networkx-3.2.tar.gz 2072917 BLAKE2B a611973897deb77f39ffca3c5e144abb1016be32f2623939150d0ea7bf2aee04e40430a00fb2ece8d8d16e8360d1da44adb14aa68798fddd1d4d3b5377360ff1 SHA512 f9fdfbe0c716c5cc6cf3f47b44e02bbd8a166724c2ef7044497b01baf468f354123aeac3c032e31293c7eedd762a29f89628cbe2ecfea280cf6012d7b0d9bdfe
EBUILD networkx-3.1.ebuild 1842 BLAKE2B 9825202ec243faf84761cff7a1cae40c6f57bd3713f1354c0a352d79a71c759eb14d4d7ef706d202237613878d29d701caadd273c61261ab4853028f9d0f13aa SHA512 cf66b237654bbe0c2cf467b7639e67746b71c7acd4082e7820235136992dc5c14b5c1a533175493170e09b00740c1c047cc4d3a5d66a3a4b41444c367b90ee1e
+EBUILD networkx-3.2.1.ebuild 1757 BLAKE2B 540e6d37177995a53d872064dd45e7a6705b05ac768ae31cb50b4d94901f1228004505bae1bf865a0ab6950c65bdacc31e21ce9a434c0d84ddceb75cd43ac843 SHA512 d2fd8b5d425be03039723013f1abf7a859accd5b970b990523af6662a71f29fb2c8d8b6d1d3facc80061912206d7c4f100bb831662330815250a47f90eba3e28
EBUILD networkx-3.2.ebuild 1777 BLAKE2B 41ec3898936b8a9f9b50b57c9468f2db8825ad0d50cd07865fe5138ac9f2957db011fe4cf64be90b301a4bc8682ac6e191aba441330f5ace6fb37986190ccbb3 SHA512 ce806f2ae9231da79f040b215e5b674cb33a2d2c15c75230389aab0afa67ce60b80c0d7b134cb60ba35e1b5ba8e4b1e2cccf5304b1ee62ebf788576cf2f65a4a
MISC metadata.xml 1090 BLAKE2B 9ef8ce06a4f462ac6a535217aa6bb55c9f1994ed3ab57b4cb656434a93a0c1fb401932307c43bd680576b82282b4055b1ee9ef1d49cfd5113927dc4919dc7616 SHA512 e9b291b754118d278b109f5704607f2d9b3807c9e6195b75b77388129952c79dba16e86f0a9c5f65479185c409c5191bb1f8863e282dde052b12d40bc9fb9901
diff --git a/dev-python/networkx/networkx-3.2.1.ebuild b/dev-python/networkx/networkx-3.2.1.ebuild
new file mode 100644
index 000000000000..ed8b9130dfa2
--- /dev/null
+++ b/dev-python/networkx/networkx-3.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{10..12} )
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing optfeature pypi virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.6[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/matplotlib-3.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.11.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # virtx implies nonfatal
+ nonfatal epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "sci-libs/gdal[python]"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}