summaryrefslogtreecommitdiff
path: root/dev-python/netaddr/netaddr-0.8.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/netaddr/netaddr-0.8.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/netaddr/netaddr-0.8.0-r1.ebuild')
-rw-r--r--dev-python/netaddr/netaddr-0.8.0-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/netaddr/netaddr-0.8.0-r1.ebuild b/dev-python/netaddr/netaddr-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..b5daaf23f914
--- /dev/null
+++ b/dev-python/netaddr/netaddr-0.8.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Network address representation and manipulation library"
+HOMEPAGE="
+ https://github.com/netaddr/netaddr/
+ https://pypi.org/project/netaddr/
+ https://netaddr.readthedocs.io/
+"
+SRC_URI="
+ https://github.com/netaddr/netaddr/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Disable coverage (requires additional plugins)
+ sed -i 's/^addopts = .*//' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ optfeature "CLI support" dev-python/ipython
+}