summaryrefslogtreecommitdiff
path: root/dev-python/nest_asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/nest_asyncio
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/nest_asyncio')
-rw-r--r--dev-python/nest_asyncio/Manifest3
-rw-r--r--dev-python/nest_asyncio/metadata.xml13
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild18
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
new file mode 100644
index 000000000000..5f3c920f9af6
--- /dev/null
+++ b/dev-python/nest_asyncio/Manifest
@@ -0,0 +1,3 @@
+DIST nest_asyncio-1.4.0.tar.gz 7053 BLAKE2B e9bdfa53f8a94ddbfd87b638962b5281aa3e8830c75a019d66d8275eb107aa7268d7f5aa24782d648a5fcfbfc4e1040abf2f2f0ca5678a513a95111d293eb055 SHA512 6a5130938baabafba30c4d5435276d33aa5df5e52a84e5646de55ab64bc01d3b69340b725b74dbe3dd158d5fba8db1470a322bdcdc3b75aa1a121076e3553a06
+EBUILD nest_asyncio-1.4.0.ebuild 405 BLAKE2B c876ce441bada97bd3543840731d3ed832f02232491416235fd05656dfba6acfb0957e64d07a17a68e1cf65d5a7a039c392c4f698b4e752fb6e9200fdc40e6a8 SHA512 239452b5fc569c115f2869fe9c3c7ff51039b8aae541dd11c0b1323041ec889fc6f5d8620ab1baf3615a1e00fd0e7763cf10022857770c059b1897739713f495
+MISC metadata.xml 426 BLAKE2B 905a2414e3fe005187fde26a1c87fa38e45437c1fc220865699f92370e51c2d260f0b71e26815e2ddf9e35c2f6bf5b3bd3f7b0e0043f72e17ac6de096a6ed16c SHA512 04ba0886e7c91629644cbff7715e7275df7e38d6b1178e411d03464726b3f777d0e2dc6716fa06ba9c8104196636af081fcd178322895d1a1694cd7b7b624bc1
diff --git a/dev-python/nest_asyncio/metadata.xml b/dev-python/nest_asyncio/metadata.xml
new file mode 100644
index 000000000000..31536e562ab6
--- /dev/null
+++ b/dev-python/nest_asyncio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <description>Python</description>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">nest_asyncio</remote-id>
+ <remote-id type="github">erdewit/nest_asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild
new file mode 100644
index 000000000000..b89a9cafeae7
--- /dev/null
+++ b/dev-python/nest_asyncio/nest_asyncio-1.4.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Patch asyncio to allow nested event loops"
+HOMEPAGE="https://github.com/erdewit/nest_asyncio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py