summaryrefslogtreecommitdiff
path: root/dev-python/nest_asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-python/nest_asyncio
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-python/nest_asyncio')
-rw-r--r--dev-python/nest_asyncio/Manifest2
-rw-r--r--dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild15
2 files changed, 13 insertions, 4 deletions
diff --git a/dev-python/nest_asyncio/Manifest b/dev-python/nest_asyncio/Manifest
index c7a4c34fd9b8..8973a8cb2aa5 100644
--- a/dev-python/nest_asyncio/Manifest
+++ b/dev-python/nest_asyncio/Manifest
@@ -1,3 +1,3 @@
DIST nest_asyncio-1.5.1.tar.gz 5738 BLAKE2B 0aa7d9a71c75b97b1eeb40dab8b2b9942a6c2107643aa82429b3d27c3fcc3602494a86903669ec3ee4f577802463cdf05cfafc4bf0c6721b251a61b079d7381a SHA512 cb85ce82706d17081de58e4176bbc6bba9efd9eec99a36902dd689010d08d4267e742cabb89c088cc274aac13ed9929f09e0f55f375cee35e3c15385ed2fe0d3
-EBUILD nest_asyncio-1.5.1.ebuild 427 BLAKE2B fa015530ddf29abc9310c3512c4109c55565860e19b42006c8bc82e05f750e0baea80a51cb8b26d477da80e4f445ac42af824327078e80da929eaa700a4e5ec9 SHA512 72c699985d632ce6c49808bc65b35af8bb270feb52de4befcc6479a0f50bc8944992cb866655701c66cfe4d6a366e6d9144e37e47143082aba5a146e381df3a6
+EBUILD nest_asyncio-1.5.1.ebuild 665 BLAKE2B 1dd4bd5bba4552debbc2ccb6bf344ad3abb3a6229fc6f8af6049b42baf6542abe535a755e935c4bfc2a546be74dd7849bd7d7962d3dfc3c6daac4b235f907eb7 SHA512 b8846201ece02472aab02d00edca71550c36f9d0ef88bff043ebe37c61184baef2888f7e98a32696afba52a801796774e92631e2674294bf1b7af2414248222e
MISC metadata.xml 388 BLAKE2B 5997502316ff6f700e55980bfccbc7ddd0b4775d95866d76803b37ad0c8e6222cf13f2ad8cbee455d6327b4f96b66f7318bcf05d3f861ecd26288ae144f8a2ba SHA512 f55ce5e44a97d4cc234f0f17f231324b72d60213b9a0c4f94d6ee4cd24893cd6592f1ab8fc6c9527d482e430cf3268299ad08e3b7f76434fce2385a5f23af174
diff --git a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
index 256fec2c5b5a..cde8a0405f28 100644
--- a/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
+++ b/dev-python/nest_asyncio/nest_asyncio-1.5.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -15,4 +15,13 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~sparc x86"
-distutils_enable_tests setup.py
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ # incorrect args in test itself
+ tests/nest_test.py::NestTest::test_two_run_until_completes_in_one_outer_loop
+ )
+ epytest ${deselect[@]/#/--deselect }
+}