summaryrefslogtreecommitdiff
path: root/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild')
-rw-r--r--dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
new file mode 100644
index 000000000000..64649d378fad
--- /dev/null
+++ b/dev-python/ndg-httpsclient/ndg-httpsclient-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE="
+ https://github.com/cedadev/ndg_httpsclient/
+ https://pypi.python.org/pypi/ndg-httpsclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="dev-python/pyopenssl[$(python_gen_usedep 'python*' pypy)]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P/-/_}"
+
+# doc build by Makefile in folder documentation is broken