summaryrefslogtreecommitdiff
path: root/dev-python/nbsphinx/nbsphinx-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-15 12:21:13 +0000
commitcf5d856691cbc347f5816a181e5bf767792afa55 (patch)
tree239945541c80dfa78133d5e9ab5c52c25a222b09 /dev-python/nbsphinx/nbsphinx-0.9.1.ebuild
parentbb007f0b04c719fd2b846d177c3c4739fdb7c318 (diff)
gentoo auto-resync : 15:03:2023 - 12:21:13
Diffstat (limited to 'dev-python/nbsphinx/nbsphinx-0.9.1.ebuild')
-rw-r--r--dev-python/nbsphinx/nbsphinx-0.9.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/nbsphinx/nbsphinx-0.9.1.ebuild b/dev-python/nbsphinx/nbsphinx-0.9.1.ebuild
new file mode 100644
index 000000000000..a8ca5203141c
--- /dev/null
+++ b/dev-python/nbsphinx/nbsphinx-0.9.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Jupyter Notebook Tools for Sphinx"
+HOMEPAGE="
+ https://github.com/spatialaudio/nbsphinx/
+ https://pypi.org/project/nbsphinx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5[${PYTHON_USEDEP}]
+"