summaryrefslogtreecommitdiff
path: root/dev-python/nbdime
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/nbdime
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/nbdime')
-rw-r--r--dev-python/nbdime/Manifest5
-rw-r--r--dev-python/nbdime/metadata.xml24
-rw-r--r--dev-python/nbdime/nbdime-0.1.2.ebuild54
-rw-r--r--dev-python/nbdime/nbdime-0.2.0.ebuild66
4 files changed, 149 insertions, 0 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
new file mode 100644
index 000000000000..e1f8c492188b
--- /dev/null
+++ b/dev-python/nbdime/Manifest
@@ -0,0 +1,5 @@
+DIST nbdime-0.1.2.tar.gz 3864624 SHA256 4adb8ff052a7c778fb5f00872172a3790504de392eb7f23b6ae96b8a8165a695 SHA512 9f704645ef1e64b0da260841769068db6f6aba37f30b3c6506a1876af1276acb452ed78f66b9e6d7029f06ed9fabf01a1484b4b86055f27a451d623a7eda90cf WHIRLPOOL 570891b1f9067abe88009f7160f509f8cba6345742df3d0549a486b8669f84c097487d25855f76ddea3ee8d786131145467ea20bedf3d54bca30a137977b7978
+DIST nbdime-0.2.0.tar.gz 4139079 SHA256 0915df792ab82fe8c3d3c892123bae0d5fb0180bafa150e2fe4dd327ff7e3c82 SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d WHIRLPOOL 0a95351be0efe993ffee5f677b62488deade3895400350c04f4743eae4bbb4e113f6fc2295ef777ecabdc9c3e27023c1d6dec4b83dc48c119ca95ea2417f9319
+EBUILD nbdime-0.1.2.ebuild 1358 SHA256 8f05dc8bc947f0396cfcb1ccdff98ecb8183f0195249c323e3e9f5916d4091d5 SHA512 04b6221791545222a081baf8a6cbaf7b043b182f8a10a42994680526f2c7bc2574de781c506a663adc0a8e5d3fd85eb82d108021c3518fcfb52806e4208018ec WHIRLPOOL 11b4b59b42ca86597197ec1f25da5526b7042915b1a10f7583139d642676f67e46c0b1baf88a5b8f749eae68eca10b5e9e72bc272b47ee3e516a877172166a59
+EBUILD nbdime-0.2.0.ebuild 1606 SHA256 2e0aee165b22312a05c4a5b966644d03ac14e2c09e80a245550bf0286b07a9f7 SHA512 ab59172c5568411dd19dbc20021bef4b8ca3404e8093a9710953eec23afea8d67736e7b9f0721b38935e7b05652a6c76577764dd1e0d78a745144011d7d86915 WHIRLPOOL e2a73961aed762257a9ce159147f086c6d6b073dcaa83e53467fc8aaaa6d61f4c2fe0480cba3c31cc86f4e5063816c75a1f0d36e4de2b4abbd87f6797c395906
+MISC metadata.xml 722 SHA256 9f1cc2aa0341cc164e3732489e7dfcf33b5643ee81327b37a73ef90e852817db SHA512 0f319098fdae96681969217b5deedafca1908b8bf47e9603ca3ecef75c4461c61e64ce0fe20e7356713d2256de8267f4abf4162be8c0098930865f464914f59d WHIRLPOOL a8cae1d520a7f8eb6868350e95fc9814244f399fc7fb720118d479f91da4f42b75f3ce50a5d62841c418eadf4c27a2fa9c418e7f9fbdd105d991686070a0e6b0
diff --git a/dev-python/nbdime/metadata.xml b/dev-python/nbdime/metadata.xml
new file mode 100644
index 000000000000..b2a229dc3754
--- /dev/null
+++ b/dev-python/nbdime/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marbre@linux.sungazer.de</email>
+ <name>Marius Brehler</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <longdescription>
+ nbdime provides tools for diffing and merging of Jupyter Notebooks.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">jupyter/nbdime</remote-id>
+ <remote-id type="pypi">nbdime</remote-id>
+ </upstream>
+ <use>
+ <flag name="webtools">
+ Install web-based diff and merge tools.
+ </flag>
+</use>
+</pkgmetadata>
diff --git a/dev-python/nbdime/nbdime-0.1.2.ebuild b/dev-python/nbdime/nbdime-0.1.2.ebuild
new file mode 100644
index 000000000000..f469ec14ebc7
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}
diff --git a/dev-python/nbdime/nbdime-0.2.0.ebuild b/dev-python/nbdime/nbdime-0.2.0.ebuild
new file mode 100644
index 000000000000..a5ed4d14c2a3
--- /dev/null
+++ b/dev-python/nbdime/nbdime-0.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Diff and merge of Jupyter Notebooks"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test webtools"
+
+RDEPEND="
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ www-servers/tornado[${PYTHON_USEDEP}]
+ webtools? ( net-libs/nodejs[npm] )
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ "
+# The package recommonmark is required to build the docs, not in portage yet.
+# Furthermore, backports.shutil_which is required for python2_7.
+
+python_configure_all() {
+ if ! use webtools; then
+ mydistutilsargs=( --skip-npm )
+ fi
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ # user.email and user.name are not configured in the sandbox.
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+
+ distutils_install_for_testing
+
+ py.test -l || die
+}