summaryrefslogtreecommitdiff
path: root/dev-python/nbdime/nbdime-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/nbdime/nbdime-0.2.0.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nbdime/nbdime-0.2.0.ebuild')
-rw-r--r--dev-python/nbdime/nbdime-0.2.0.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/nbdime/nbdime-0.2.0.ebuild b/dev-python/nbdime/nbdime-0.2.0.ebuild
deleted file mode 100644
index d407d7d26d2f..000000000000
--- a/dev-python/nbdime/nbdime-0.2.0.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="http://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc test webtools"
-
-RDEPEND="
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- webtools? ( net-libs/nodejs[npm] )
- "
-DEPEND="${RDEPEND}
- doc? (
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
- "
-# The package recommonmark is required to build the docs, not in portage yet.
-# Furthermore, backports.shutil_which is required for python2_7.
-
-python_configure_all() {
- if ! use webtools; then
- mydistutilsargs=( --skip-npm )
- fi
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- # user.email and user.name are not configured in the sandbox.
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- distutils_install_for_testing
-
- py.test -l || die
-}