summaryrefslogtreecommitdiff
path: root/dev-python/nbclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-python/nbclient
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-python/nbclient')
-rw-r--r--dev-python/nbclient/Manifest2
-rw-r--r--dev-python/nbclient/nbclient-0.7.2.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/nbclient/Manifest b/dev-python/nbclient/Manifest
index 9e7f30512d53..0677a516278c 100644
--- a/dev-python/nbclient/Manifest
+++ b/dev-python/nbclient/Manifest
@@ -1,3 +1,5 @@
DIST nbclient-0.7.0.gh.tar.gz 78253 BLAKE2B 473dcef140c8e1fc8f1e97fa30859b9b9fc2dfd6f951ae52db8ab11febbb3de7f60d129424827983a2c05579cd2340e9d4e1a9d0e452a7678497fc1c7176ecf3 SHA512 93d22e2b4fe1740798b812bb4890bf2fe2c7fdd337e34b50eac3140ead73d443cdb326948b2e8511b6ccad61c7daf1efd8e7cc3664b6b1ad9dda0894ca84fff5
+DIST nbclient-0.7.2.gh.tar.gz 76883 BLAKE2B d90b9dd7b15757a44c86084b68b916aab663c0e20a5c1012bda9f86a0ec1104a01cd78d27bc6e510eceeee12f2356a312d8080e1568e4c54dd2e916af85dc304 SHA512 17f1bfbfa156688e895ab1a0d0f74903f43c62a373a40cfcc50a654d86ebbaeb5ed101562716140a3878a9667bb131c49e06caf2e3127160700baf181cd1c29b
EBUILD nbclient-0.7.0.ebuild 1478 BLAKE2B 60bf2d52e8a8dff8469d21ce72786a29c6aebd19e667c9e46044b0faf96ba5bb30eeb57a11dbb7aaff685a1833f7c7ba9ed21ec7f11673d274fb37247816af9f SHA512 f18306d5364c3187f97e48327808e0ee4e2c490bf0961c1e92238f8e8734aa37409ad51edb04c97ad9c89ac528a85865ef114e18fdb57dc877c32679a1fb182a
+EBUILD nbclient-0.7.2.ebuild 1585 BLAKE2B 5ddd1e8b8564bd26e73453cde8328c1f94506e02345f0f9a6e448d3e1bf8bde3d00c7f3e5dc9a1fcfac98448caac1edcb3071104b93cedb66e4b3f56d2f7f0f9 SHA512 a78f4da02b1b5c3dd8791b5317095fb1a7a3b0a52b317a19ec716202be6d66fa27ab1593e7f9fc5fb49af2b66a35462da1d1103dbdd9ef6d28cf4f233c5a99f9
MISC metadata.xml 405 BLAKE2B d1efa5f7bb2a959bdbc6093b1bd3930e6cdb9bffbe872c6775c15dfc1024ae24d6bcb4651c8e1fb06242b17d6a86f683de3b528bbf1a60b5656a90c1f4ac81b7 SHA512 5b0de690d37dd5928e3bfd0b380336d154cced094e342b41dfd16d0caddd2b792a2158b209404a36461cf4d1b12d836024eae2aedf15093b90f4e363382b38bf
diff --git a/dev-python/nbclient/nbclient-0.7.2.ebuild b/dev-python/nbclient/nbclient-0.7.2.ebuild
new file mode 100644
index 000000000000..bef4d0ab4373
--- /dev/null
+++ b/dev-python/nbclient/nbclient-0.7.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client library for executing Jupyter notebooks"
+HOMEPAGE="
+ https://nbclient.readthedocs.io/en/latest/
+ https://github.com/jupyter/nbclient/
+ https://pypi.org/project/nbclient/
+"
+SRC_URI="
+ https://github.com/jupyter/nbclient/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-6.1.12[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.12[${PYTHON_USEDEP}]
+ <dev-python/jupyter_core-5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.0[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipywidgets[${PYTHON_USEDEP}]
+ dev-python/nbconvert[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ nbclient/tests/test_client.py::test_many_parallel_notebooks
+ 'nbclient/tests/test_client.py::test_run_all_notebooks[Interrupt.ipynb-opts6]'
+)
+
+python_test() {
+ # The tests run the pydevd debugger, the debugger prints a warning
+ # in python3.11 when frozen modules are being used.
+ # This warning makes the tests fail, silence it.
+ PYDEVD_DISABLE_FILE_VALIDATION=1 epytest
+}