summaryrefslogtreecommitdiff
path: root/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-05 21:17:55 +0000
commit519f4aac6d5896fe0204e6429485f95240c7ff58 (patch)
tree467adac90d818b96465a433b66ef6bb65e369fef /dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
parent8afe4133ba3d8586301516885427809020a3cafa (diff)
gentoo auto-resync : 05:02:2023 - 21:17:55
Diffstat (limited to 'dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild')
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild b/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
new file mode 100644
index 000000000000..7dfecc74deb8
--- /dev/null
+++ b/dev-python/mypy_extensions/mypy_extensions-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Type system extensions for programs checked with mypy"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy_extensions/
+"
+SRC_URI="
+ https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests/*.py
+}