summaryrefslogtreecommitdiff
path: root/dev-python/mypy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 20:08:44 +0000
commit6554f04b9a44e1ffe5d2f614201c11deed2703bd (patch)
tree4a6f98988d23282385c916fa1c677b094d10461a /dev-python/mypy
parent7c9730bcb62df7cbf8248c5db9a478aac52c60ea (diff)
gentoo auto-resync : 17:02:2023 - 20:08:44
Diffstat (limited to 'dev-python/mypy')
-rw-r--r--dev-python/mypy/Manifest2
-rw-r--r--dev-python/mypy/mypy-1.0.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index d9e54512af9d..06b2cf57de6a 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,5 +1,7 @@
DIST mypy-0.991.gh.tar.gz 2694440 BLAKE2B 857c991a17f5a0195d5c7db60e73427695b64d3c3181b26919ed40a2b825ef5e8f30890a4ca7a55b739087af47f025b1d324563f5ef5e2f58c363562ecc49365 SHA512 02663494700d4ab6d08ab2199a7a81ad144ed090774326ea8d418dec37faec6d3b078f1c3120b8b014a676d69d5dc4e9b528b759c2de086a18569016b28b00d5
DIST mypy-1.0.0.gh.tar.gz 2763277 BLAKE2B 063bb131f348eba554737f457bb19bae44eb07f395682452d6a8de60244dc5fc305e3bd8dfdc34f479003f0aa195694db8a879a3eab2bba7b324ff0c189e324a SHA512 c80ad21dffe937ed247fb259a4eb11530921c87313233e99754b25cedbf9314139b397edb22067a6031f689ac3e409ee97f9d011aa82724d77f4dfaffaa39169
+DIST mypy-1.0.1.gh.tar.gz 2763553 BLAKE2B d8d2b6cd3ff386ce0f78d32f81f3f631bbb8ffdbebab8607af2496c890b6a876f870e487a88711b93e48615548aaf6fa32cc6f62cf472d2def59374b49818584 SHA512 081b1ada479ea694e570f6ac56e470196efe30cc5bd8d8e32255ca980a312d67779746eb3f780ecb4d83e8d7e3272fcc77231ba098e736be5893cf249b7ff84e
EBUILD mypy-0.991.ebuild 1763 BLAKE2B 92329440451f1324563d0a1f11d84c1037271a6691048f6132de70268991d9f9080a3447d9172c3a5292c65bf6d693c66176fa2ce7d76afd542f60642f9f8d34 SHA512 62506ce8a43b1af1896d742104146a9952ee31429d704ff14fba96456849195a94560fb5f1aec342472d1ccd2a2a688336f3b2b8c5417ca013d65420b98f7e43
EBUILD mypy-1.0.0.ebuild 1772 BLAKE2B ed954a628ba6f5155642d519e7b0750764b7619c5f1ea1fa53f2cf3a73c29e75595358871b490bc77cc5d2798cfbf31e36abfac2b1d2dd5842857448cabbbb92 SHA512 9ed5a549ace985a257025be8897d4146bdbc007a19f53115d198afdcb77d0656a3ab46e1e1d1e5dcff549076e8d8da8e934149a2889935b05f631e50d8bd8578
+EBUILD mypy-1.0.1.ebuild 1772 BLAKE2B ed954a628ba6f5155642d519e7b0750764b7619c5f1ea1fa53f2cf3a73c29e75595358871b490bc77cc5d2798cfbf31e36abfac2b1d2dd5842857448cabbbb92 SHA512 9ed5a549ace985a257025be8897d4146bdbc007a19f53115d198afdcb77d0656a3ab46e1e1d1e5dcff549076e8d8da8e934149a2889935b05f631e50d8bd8578
MISC metadata.xml 515 BLAKE2B 75827bbbeb70fd4b9295ab4689068d2d4b686b32d4059acde94fb0d08048e9e56ecaf3eec39dc5567b2753e2552353e273cdf2f4e27d077cc9b03320ee09c64b SHA512 c1c3c7a3651e61e0b63ab4462f0370cce9cbdce33e64c5e7a1fbefe8116d5d3d3b35bc4095d8a5ce28caf69b0644af3f13c9a27b683f2f981e52f8bfe4ac8615
diff --git a/dev-python/mypy/mypy-1.0.1.ebuild b/dev-python/mypy/mypy-1.0.1.ebuild
new file mode 100644
index 000000000000..af0edc51916c
--- /dev/null
+++ b/dev-python/mypy/mypy-1.0.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ https://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-2[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.10[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/furo
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}