summaryrefslogtreecommitdiff
path: root/dev-python/mypy/mypy-0.600.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/mypy/mypy-0.600.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mypy/mypy-0.600.ebuild')
-rw-r--r--dev-python/mypy/mypy-0.600.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/dev-python/mypy/mypy-0.600.ebuild b/dev-python/mypy/mypy-0.600.ebuild
deleted file mode 100644
index 667a3dc20fec..000000000000
--- a/dev-python/mypy/mypy-0.600.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-if [ "${PV}" == "9999" ]; then
- inherit distutils-r1 git-r3
- EGIT_REPO_URI="https://github.com/python/${PN}"
- SRC_URI=""
-else
- inherit distutils-r1
- TYPESHED_COMMIT="2dc7d39"
- SRC_URI="https://github.com/python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://api.github.com/repos/python/typeshed/tarball/${TYPESHED_COMMIT} -> mypy-typeshed-${PV}-${TYPESHED_COMMIT}.tar.gz"
-fi
-
-DESCRIPTION="Optional static typing for Python"
-HOMEPAGE="http://www.mypy-lang.org/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/flake8[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
- )
-"
-CDEPEND="
- !dev-util/stubgen
- >=dev-python/psutil-5.4.0[${PYTHON_USEDEP}]
- <dev-python/psutil-5.5.0[${PYTHON_USEDEP}]
- >=dev-python/typed-ast-1.1.0[${PYTHON_USEDEP}]
- <dev-python/typed-ast-1.2.0[${PYTHON_USEDEP}]
- "
-
-RDEPEND="${CDEPEND}"
-
-src_unpack() {
- if [ "${PV}" == "9999" ]; then
- git-r3_src_unpack
- else
- unpack ${A}
- rmdir "${S}/typeshed"
- mv "${WORKDIR}/python-typeshed-${TYPESHED_COMMIT}" "${S}/typeshed"
- fi
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- local PYTHONPATH="$(pwd)"
-
- "${PYTHON}" runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
-
- distutils-r1_python_install_all
-}