summaryrefslogtreecommitdiff
path: root/dev-python/musicbrainzngs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-20 21:54:06 +0100
commit62058fa8f1b95418543f8ae008b247d44cc8b09c (patch)
tree48811edf87b513f58aff374c669cdfd5b1827e15 /dev-python/musicbrainzngs
parentb3830a745865c7d85daf3317603ad23dac6434da (diff)
gentoo auto-resync : 20:10:2023 - 21:54:06
Diffstat (limited to 'dev-python/musicbrainzngs')
-rw-r--r--dev-python/musicbrainzngs/Manifest5
-rw-r--r--dev-python/musicbrainzngs/metadata.xml22
-rw-r--r--dev-python/musicbrainzngs/musicbrainzngs-0.7.1-r1.ebuild38
-rw-r--r--dev-python/musicbrainzngs/musicbrainzngs-0.7.1.ebuild38
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-python/musicbrainzngs/Manifest b/dev-python/musicbrainzngs/Manifest
new file mode 100644
index 000000000000..dfc093222743
--- /dev/null
+++ b/dev-python/musicbrainzngs/Manifest
@@ -0,0 +1,5 @@
+DIST python-musicbrainzngs-0.7.1.gh.tar.gz 112302 BLAKE2B 1c0696c72b8ea78d182300c76c0040117e1448a7955fa9aed8e42d1ebf9aa1b43359cee1158920fa31d3fb7536796130b54d0d45f351ddb5449d8f022a55f552 SHA512 a674c38b5084d1ae554dd03d1b3e613b48f8f3f3ada67f8d608130cebd35f0640ca65f8b4d224c1e660975274b0b077ffae29739ac2dc5a7078ca87eb8ccadd9
+DIST python-musicbrainzngs-0.7.1.tar.gz 112302 BLAKE2B 1c0696c72b8ea78d182300c76c0040117e1448a7955fa9aed8e42d1ebf9aa1b43359cee1158920fa31d3fb7536796130b54d0d45f351ddb5449d8f022a55f552 SHA512 a674c38b5084d1ae554dd03d1b3e613b48f8f3f3ada67f8d608130cebd35f0640ca65f8b4d224c1e660975274b0b077ffae29739ac2dc5a7078ca87eb8ccadd9
+EBUILD musicbrainzngs-0.7.1-r1.ebuild 853 BLAKE2B aaba9fe52bc8d9d3974599e66db9b02a5dd2905ce1baa0a2f5cdc5f38af9a3db9e525b51988efbed65a2b81332850464f792ea06ca92d433a331c8bddd4ee81d SHA512 badb85e087e3ce476346c0877b2d7a67a6a45220089b750a8ee3db3be5305157694a666d69d73462e14e87b3b19294e927ff5b9595e2c3f490b4856abb55b964
+EBUILD musicbrainzngs-0.7.1.ebuild 923 BLAKE2B 03c35e214f0eef46248c1f7003b87a29466fe632b34aa79363c55a10e572fa3c500090863bbb9ed7a4ba1b9a212d3bd1e073d7ecbe55ac379a9eb472d18353e6 SHA512 f7af69d16fe71ac0dfd19671892c4fb09ca188de91b05ad4c793524d18a525f64701f5aed7c2b77c9d476a5a37bf924dcbecf6dbfe6954cea1b7a4682f4316a3
+MISC metadata.xml 956 BLAKE2B 303ca1974b515a169af790ef2ab6f8aed0bb2b60c7a41d8b3b2d8ba7352a3c0cffb42f1886bb280c559e34b748d74c319fe0ab1126208637561b78b16b17e00d SHA512 dbc7cdf2c1ec2314778e963aee5daa805b1004cb5013d7fbb9b356554c9ae6cbc5cfb66e40de50cf6caefaa856e65517675a622b2f23c52949a74d490c13b5b2
diff --git a/dev-python/musicbrainzngs/metadata.xml b/dev-python/musicbrainzngs/metadata.xml
new file mode 100644
index 000000000000..33ce9f0483c7
--- /dev/null
+++ b/dev-python/musicbrainzngs/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>gerion.entrup@flump.de</email>
+ <name>Gerion Entrup</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ This library implements webservice bindings for the Musicbrainz NGS site, also known as /ws/2 and the Cover Art Archive.
+ With this library you can retrieve all kinds of music metadata from the MusicBrainz database.
+ The library can retrieve and submit both, the XML and JSON based webservice and provides the data in native Python.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">alastair/python-musicbrainzngs</remote-id>
+ <remote-id type="pypi">musicbrainzngs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/musicbrainzngs/musicbrainzngs-0.7.1-r1.ebuild b/dev-python/musicbrainzngs/musicbrainzngs-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..16c5b836b431
--- /dev/null
+++ b/dev-python/musicbrainzngs/musicbrainzngs-0.7.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-musicbrainzngs-${PV}
+DESCRIPTION="Python bindings for the MusicBrainz NGS and the Cover Art Archive webservices"
+HOMEPAGE="
+ https://github.com/alastair/python-musicbrainzngs/
+ https://pypi.org/project/musicbrainzngs/
+"
+SRC_URI="
+ https://github.com/alastair/python-musicbrainzngs/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2 ISC"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/musicbrainzngs/musicbrainzngs-0.7.1.ebuild b/dev-python/musicbrainzngs/musicbrainzngs-0.7.1.ebuild
new file mode 100644
index 000000000000..f1467c24aa57
--- /dev/null
+++ b/dev-python/musicbrainzngs/musicbrainzngs-0.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+inherit distutils-r1
+
+MY_P=python-musicbrainzngs-${PV}
+DESCRIPTION="Python bindings for the MusicBrainz NGS and the Cover Art Archive webservices"
+HOMEPAGE="https://github.com/alastair/python-musicbrainzngs"
+SRC_URI="
+ https://github.com/alastair/python-musicbrainzngs/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2 ISC"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # Prevent un-needed d'loading
+ sed -e "s/^ *'sphinx.ext.intersphinx'//" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}